summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-03-24 17:08:58 +0100
committerSebastian Pipping <sping@gentoo.org>2021-03-24 17:10:33 +0100
commit0d6b4f77e689f30c9a9fc7f0012caec35c338ed3 (patch)
tree15af3a4f2b263eee322ba3e276fd708f46ba3f6f
parentsys-power/nvclock: revbump for d-m-i (diff)
downloadgentoo-0d6b4f77e689f30c9a9fc7f0012caec35c338ed3.tar.gz
gentoo-0d6b4f77e689f30c9a9fc7f0012caec35c338ed3.tar.bz2
gentoo-0d6b4f77e689f30c9a9fc7f0012caec35c338ed3.zip
www-client/httrack: Fix libdir patching
Closes: https://bugs.gentoo.org/777996 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.17, Repoman-3.0.2
-rw-r--r--www-client/httrack/httrack-3.49.2-r2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r2.ebuild b/www-client/httrack/httrack-3.49.2-r2.ebuild
index a6bded23cc64..6dc538f59283 100644
--- a/www-client/httrack/httrack-3.49.2-r2.ebuild
+++ b/www-client/httrack/httrack-3.49.2-r2.ebuild
@@ -33,9 +33,11 @@ src_prepare() {
# linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
# The grep sandwich acts as a regression test so that a future
# version bump cannot break patching without noticing.
- grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
- sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
- grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+ if [[ "$(get_libdir)" != lib ]]; then
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+ fi
eautoreconf
}