summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-02 22:14:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-03 00:26:48 +0200
commit0d6d2f826cc26dfcf329ff1499abc9bb0169caa1 (patch)
treef51343763f4ca3fb3a8cb1cfeab5dfe7566719a9
parentdev-util/valgrind: Add patch to support linking with LLD (diff)
downloadgentoo-0d6d2f82.tar.gz
gentoo-0d6d2f82.tar.bz2
gentoo-0d6d2f82.zip
dev-python/nuitka: Bump to 0.6.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.16.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 8a28ba5afba1..c70cdf42c45e 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -2,4 +2,5 @@ DIST Nuitka-0.6.11.tar.gz 2582563 BLAKE2B e65c3a01f3283b24aadefc47a17a41ebae1162
DIST Nuitka-0.6.15.1.tar.gz 2712603 BLAKE2B 8e639b19975410143d1b91b4fb4f71c65bd1d9382c07d2f1f431c16b687954cec62c2e4dbe9bb1c6f6981dda1948a87040b2e300919dbe72c7d6bfd0772b73c2 SHA512 70bdb55ff4b57f06f67e3026c6a1fbeaa729e85f0a7e698ba0ab40c4acaebd31925327dd0f5fbf8187779421968bf29f9b0fbc2995193468411b40a1d30889e2
DIST Nuitka-0.6.15.3.tar.gz 2713332 BLAKE2B e8d61221839bb961cda14575aa1de5979510113a09b7e8df47aefbf8985b09f554b32210db9b91ca5f02593a11d7537adcdf0fd67d397b022623534bb25368c3 SHA512 960f2ef33aa2c4dcb6a86ed15b8d8fc8ca1c5f26a0dc98a925e8c0669599912f25d10e20f547d51d57c0a63a18e2f07fa45141666b740b3d8804014db5b89bb6
DIST Nuitka-0.6.15.tar.gz 2712097 BLAKE2B 78c43be4a2ef5678d7a0d6164d7cba2b3a67a738215915b001cdb3774e209fcecc167c52db4c3b22d87dde9169e48077875d09f8601df7c8b079e3d57b21aea6 SHA512 9a41e9b8fb3f51ec16dccd5415b3b7d7d201230fea6aff902931be1764ba65e1d5e4885cd772b4c1cb9f36b1b14a02a73351bc5c1b8e7f7bbb87e5d74aad16b4
+DIST Nuitka-0.6.16.2.tar.gz 2964589 BLAKE2B b8dd49b889ab0921b6bcf25528286c72591d12e470074482be2f2919394d7c7281d15f83fe1283731a45731a6164a72fb19afc5f55c7c7ef913487cadc6af105 SHA512 58fbd015cf14f947900ccb39a82a24ba8b2da6b65f41caa6bdaff89fe8b5b00977b2f0f3e2b9c2809db97539ecb59f2835ebc30eccd726d42b3fbb49cd90ca8c
DIST Nuitka-0.6.16.tar.gz 2891639 BLAKE2B 4d8b9c29115e333b7a876eed664c0ec7b2a9b25b00d35bfb163834579b28d6b1250b015eacced01e2c27cd9841fcc5d2a3b10c626a5c7fc098914e675e3732a6 SHA512 908ddbab62a085a478f09c18215fd9b457aa7fe926e5809cd25870665366660f59141b431346e4af6593e4bb0281d39103919c46435c158af6f2ba7c354c3834
diff --git a/dev-python/nuitka/nuitka-0.6.16.2.ebuild b/dev-python/nuitka/nuitka-0.6.16.2.ebuild
new file mode 100644
index 000000000000..8810e82b4d14
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.16.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}