summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-18 16:14:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-18 16:47:37 +0100
commit0d7229582dc57f24f013d76bd180ae1785c05b49 (patch)
tree8b6c147aa4ad335ecf034cf02b6159bad4b9952a
parentdev-python/python-mpv: Bump to 1.0.5 (diff)
downloadgentoo-0d7229582dc57f24f013d76bd180ae1785c05b49.tar.gz
gentoo-0d7229582dc57f24f013d76bd180ae1785c05b49.tar.bz2
gentoo-0d7229582dc57f24f013d76bd180ae1785c05b49.zip
dev-python/jupyterlab-server: Bump to 2.25.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.25.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index ecc94363f2d1..c251e7a3f2c4 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1,2 +1,3 @@
DIST jupyterlab_server-2.25.0.tar.gz 72251 BLAKE2B aac9191493833aea1dbd2b2b85365bab2bfbf06576c853668cc94d62b03b8cabaabc2df8c76ae57c8d76d55ddf646bdf51de00f682cc5b4b27252d5bd409bc61 SHA512 b97a1e5da8f30e83971be152a39c5a6553e6a589000f4848feb7777561b018b310f445853825215cfdb823666d73d4b117ed8914138c8a319035dac893f85951
DIST jupyterlab_server-2.25.1.tar.gz 73845 BLAKE2B a2eb8ac0d6ffe76cf8e2bc2464c9466ed098acb03ad8fd50bfcf87b461366d0a877d3e3311382c1c1f0e4046a42b8adb58ffd21ef5a58611115e5a5986f20316 SHA512 179c3fc0f09c2456b5be8ae2d35e809df63766dd3e5b740eb9e9d5630152aa8bef6f1ad08602e0bda5860cdad0d681d771cd22eac4ea8b6fc07ad8609e83e810
+DIST jupyterlab_server-2.25.2.tar.gz 74028 BLAKE2B 6dffdea7c002fee946a8af728592ea2404f4568bdfaae1727da5c3725edb284a7ad8594efdf71a4671249a4164878288bcb4aa588a59f45fa83fbda0656db89b SHA512 6270505170e7586fae8c4f7fcabaed6e2ef2068ec35bc5eb630e1b5177aab24d8e8be4755ad6dd3f97c5e3a1aa6c770f554efe92a2db5a5bfe99bf420e2b5a34
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.25.2.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.25.2.ebuild
new file mode 100644
index 000000000000..f78ef98f9e9b
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.25.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.19[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.18[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin -p timeout
+}