summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMats Lidell <matsl@gentoo.org>2022-12-25 18:21:58 +0100
committerMats Lidell <matsl@gentoo.org>2022-12-25 18:28:08 +0100
commit0d74bc064b54667e514fbc23ca2e61cc8bcd7430 (patch)
tree05af02d5824264bb8105f83b0f4184d658d52bf6
parentdev-cpp/yaml-cpp: Stabilize 0.7.0-r2 arm64, #888425 (diff)
downloadgentoo-0d74bc064b54667e514fbc23ca2e61cc8bcd7430.tar.gz
gentoo-0d74bc064b54667e514fbc23ca2e61cc8bcd7430.tar.bz2
gentoo-0d74bc064b54667e514fbc23ca2e61cc8bcd7430.zip
app-editors/xemacs: update EAPI 7 -> 8
Do not add debug flag on regular builds. Cleanup: Remove commented out patches. Signed-off-by: Mats Lidell <matsl@gentoo.org>
-rw-r--r--app-editors/xemacs/xemacs-21.5.9999.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/app-editors/xemacs/xemacs-21.5.9999.ebuild b/app-editors/xemacs/xemacs-21.5.9999.ebuild
index 2cfa5ff7eba1..c164858b40dd 100644
--- a/app-editors/xemacs/xemacs-21.5.9999.ebuild
+++ b/app-editors/xemacs/xemacs-21.5.9999.ebuild
@@ -4,7 +4,7 @@
# Note: xemacs currently does not work with position independent code
# so the build forces the use of the -no-pie option
-EAPI=7
+EAPI=8
inherit flag-o-matic xdg-utils desktop
@@ -62,14 +62,6 @@ src_unpack() {
src_prepare() {
use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
find "${S}"/lisp -name '*.elc' -exec rm {} \; || die
- # eapply "${FILESDIR}/${P}-ncurses-tinfo.patch"
- # eapply "${FILESDIR}/${P}-gcc5.patch"
- # eapply "${FILESDIR}/${P}-glibc-macro.patch"
- # eapply "${FILESDIR}/${P}-as-needed.patch"
- # eapply "${FILESDIR}/${P}-configure-libc-version.patch"
- # eapply "${FILESDIR}/${P}-ar.patch"
- # eapply "${FILESDIR}/${P}-strsignal.patch"
- # eapply "${FILESDIR}/${P}-process-test-qa.patch"
eapply_user
@@ -166,7 +158,7 @@ src_configure() {
fi
use debug && myconf="${myconf} --with-debug" ||
- myconf="${myconf} --with-optimization"
+ myconf="${myconf} --with-optimization --with-cflags-debugging="
econf ${myconf} \
$(use_with gif ) \