summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-08-28 21:13:49 +0300
committerStefan Strogin <steils@gentoo.org>2019-08-28 21:22:49 +0300
commit0d7adab330e514eb0dce33d2173d3b901feb8726 (patch)
tree8611296cce991868d0523109a7b54c7d982ccf96
parentdev-python/async_timeout: Remove old versions (diff)
downloadgentoo-0d7adab3.tar.gz
gentoo-0d7adab3.tar.bz2
gentoo-0d7adab3.zip
app-misc/tmate: bump version to 2.3.0
- Add USE=libressl. - EAPI=7. - Correct LICENSE. Closes: https://bugs.gentoo.org/614222 Closes: https://bugs.gentoo.org/683116 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--app-misc/tmate/Manifest1
-rw-r--r--app-misc/tmate/tmate-2.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/tmate/Manifest b/app-misc/tmate/Manifest
index aa8903f05859..d5df5da5e894 100644
--- a/app-misc/tmate/Manifest
+++ b/app-misc/tmate/Manifest
@@ -1,3 +1,4 @@
DIST tmate-2.2.0-upstream-patches-0.tar.xz 6784 BLAKE2B b21a2065ba7a7832238cb6b6bbfe3e730593766a34244e139d0e357cad538a4462e68a9e884a6250fc72a10a775fa13e53054618c35804cc05ad0cc31854d9e3 SHA512 3e16e0b7988d3d1942fcac0a535d2cc8d7156d26332dc84fd21c4761afae40159282b0fbeb71cd5f6525b5a1c7a46e7813c8e6a11851592077570c1a001a73a7
DIST tmate-2.2.0.tar.gz 610793 BLAKE2B febe2ed652e8387f65d938f09c6abbd92841a71a285035f6322bcf786aa4f80f71a0f49fc475743a8565bf4c7e434d9f503ffc6bae26d531429b1c58bc0ffbe9 SHA512 e9429833cdb8c28873d01bfc6b9a0d1241e30346ef1b3efae6763389c8444943b831283c1ea65e49c68d11936d6586186b38e0f7c14d373d9f63e841026c3338
DIST tmate-2.2.1.tar.gz 610745 BLAKE2B 8a97d7726b528d12e14c74c07f795b18510a4b7a0068f1e1168b06e2a6856945518b3b9a35f71ba8598b8f9390d754443eca197f95f5c9c61d6160f4008ff65d SHA512 3d4ce7510cd8da39bc4fe63f2a64179846a813bb3560ca811d9e1e2a28b06d95a9033047a900d76bda069c249d7ebbe1143daa082b23212c5d32a50bf1819d2d
+DIST tmate-2.3.0.tar.gz 611262 BLAKE2B c4e789b20fbfb1736eacbf36f368d8ceb573937ed2c72f2b79b8da175a811985af12d9823fdbade9ee3f72bfb43427e8fa64eea75ba5fc3cf64273c31856d4d6 SHA512 b7de8f28ab5ee8ea389d4882ed64de3d71bd53d626ae6bf323d5be732066e63a7dba2a85318c0202a088af53df7e0d976256c1253895ad81739d270ee65d0eb7
diff --git a/app-misc/tmate/tmate-2.3.0.ebuild b/app-misc/tmate/tmate-2.3.0.ebuild
new file mode 100644
index 000000000000..bdddbdf93b17
--- /dev/null
+++ b/app-misc/tmate/tmate-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Instant terminal sharing"
+HOMEPAGE="https://tmate.io/"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl static-libs"
+
+SRC_URI="https://github.com/tmate-io/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+RDEPEND="
+ sys-libs/zlib[static-libs?]
+ sys-libs/libutempter[static-libs?]
+ dev-libs/libevent[static-libs?]
+ dev-libs/msgpack[static-libs?]
+ >=net-libs/libssh-0.6.0[static-libs?]
+ !libressl? ( dev-libs/openssl:0=[static-libs?] )
+ libressl? ( dev-libs/libressl:0=[static-libs?] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}