summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 20:50:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 20:50:51 +0200
commit0d851abffe1d5846d636feed69d6dd012b531903 (patch)
treecedeb6f4eb2396687be3f7aae6a28f6cfd018891
parentmedia-libs/libsndfile: Security cleanup (diff)
downloadgentoo-0d851abf.tar.gz
gentoo-0d851abf.tar.bz2
gentoo-0d851abf.zip
media-libs/libsndfile: Sync 9999 with 1.0.28-r3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--media-libs/libsndfile/libsndfile-9999.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/media-libs/libsndfile/libsndfile-9999.ebuild b/media-libs/libsndfile/libsndfile-9999.ebuild
index eb28af81fd55..1b23d4798036 100644
--- a/media-libs/libsndfile/libsndfile-9999.ebuild
+++ b/media-libs/libsndfile/libsndfile-9999.ebuild
@@ -1,26 +1,21 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-inherit python-any-r1 multilib-minimal
-
-DESCRIPTION="A C library for reading and writing files containing sampled sound"
-HOMEPAGE="http://www.mega-nerd.com/libsndfile"
-
if [[ ${PV} == *9999 ]]; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/erikd/libsndfile.git"
-
- DEPEND="
- ${PYTHON_DEPS}
- sys-devel/autogen"
else
SRC_URI="http://www.mega-nerd.com/libsndfile/files/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
fi
+inherit python-any-r1 multilib-minimal
+
+DESCRIPTION="C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -34,11 +29,16 @@ RDEPEND="
)
alsa? ( media-libs/alsa-lib )
sqlite? ( >=dev-db/sqlite-3.2 )"
-DEPEND="
- ${DEPEND}
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
test? ( ${PYTHON_DEPS} )"
+if [[ ${PV} == *9999 ]]; then
+ BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/autogen
+ "
+fi
pkg_setup() {
if use test || [[ ${PV} == *9999 ]]; then