summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-25 23:16:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-25 23:16:43 +0100
commit0d941ef9776cdc5d3699dbf762fb180fc1468c30 (patch)
tree830545be7f47fd1073122771e763dc54a75b24e9
parentsys-process/procps: Revbump to fix pgrep/pkill with kernel-5.10+ (diff)
downloadgentoo-0d941ef9.tar.gz
gentoo-0d941ef9.tar.bz2
gentoo-0d941ef9.zip
sys-process/procps: Removed old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-process/procps/Manifest1
-rw-r--r--sys-process/procps/procps-3.3.15-r1.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/sys-process/procps/Manifest b/sys-process/procps/Manifest
index c5db62714874..8314da21d26b 100644
--- a/sys-process/procps/Manifest
+++ b/sys-process/procps/Manifest
@@ -1,2 +1 @@
-DIST procps-ng-3.3.15.tar.xz 904416 BLAKE2B 9fc1384df1d51a13bdf3aaad173160a11c5a7e016a8c397a076b5115e350d2c6fd8ff8d9ad5d83b959020bcd6a1ef9e1bca02e9a63d56881816c5c7d7c9a8bc3 SHA512 bc83ccc1941e7be8266588fdfbba17e2424b30163a215873ee6dee96215d66249f5d5e46fec2278d030b42bd7599861c4878360042dacec4c221ce411453747c
DIST procps-ng-3.3.16.tar.xz 859736 BLAKE2B fbacc1edb0711cda0fecbf5f589c8cc18bd74f0430866e946f7c4612b78f383b9299840ab7fa5bbc65c581cc9484dbb37b111c493cf88f55ba247a343fd0c80d SHA512 d83da472df256b188c32082632202e7f8ebd1b161082387760876ae34d50221b3682299a2816a7d6a29afb40322743c31b87d92ca299c2944a6b55e50736d367
diff --git a/sys-process/procps/procps-3.3.15-r1.ebuild b/sys-process/procps/procps-3.3.15-r1.ebuild
deleted file mode 100644
index 9c45dfc2ce86..000000000000
--- a/sys-process/procps/procps-3.3.15-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic usr-ldscript
-
-DESCRIPTION="standard informational utilities and process-handling tools"
-HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
-SRC_URI="mirror://sourceforge/${PN}-ng/${PN}-ng-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/6" # libprocps.so
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- elogind? ( sys-auth/elogind )
- ncurses? ( >=sys-libs/ncurses-5.7-r7:=[unicode?] )
- selinux? ( sys-libs/libselinux )
- systemd? ( sys-apps/systemd )
-"
-DEPEND="${COMMON_DEPEND}
- elogind? ( virtual/pkgconfig )
- ncurses? ( virtual/pkgconfig )
- systemd? ( virtual/pkgconfig )
- test? ( dev-util/dejagnu )"
-RDEPEND="
- ${COMMON_DEPEND}
- kill? (
- !sys-apps/coreutils[kill]
- !sys-apps/util-linux[kill]
- )
- !<sys-apps/sysvinit-2.88-r6
-"
-
-S="${WORKDIR}/${PN}-ng-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.11-sysctl-manpage.patch # 565304
- "${FILESDIR}"/${PN}-3.3.12-proc-tests.patch # 583036
-
- # Upstream fixes
-)
-
-src_configure() {
- # http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
- append-lfs-flags #471102
- local myeconfargs=(
- $(use_with elogind)
- $(use_enable kill)
- $(use_enable modern-top)
- $(use_with ncurses)
- $(use_enable nls)
- $(use_enable selinux libselinux)
- $(use_enable static-libs static)
- $(use_with systemd)
- $(use_enable unicode watch8bit)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- emake check </dev/null #461302
-}
-
-src_install() {
- default
- #dodoc sysctl.conf
-
- dodir /bin
- mv "${ED%/}"/usr/bin/ps "${ED%/}"/bin/ || die
- if use kill; then
- mv "${ED%/}"/usr/bin/kill "${ED}"/bin/ || die
- fi
-
- gen_usr_ldscript -a procps
- find "${D}" -name '*.la' -delete || die
-}