summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2023-02-25 11:06:06 +0100
committerFabian Groffen <grobian@gentoo.org>2023-02-25 11:18:47 +0100
commit0da148654a41181a2c2a50ec641706731b906201 (patch)
tree4c75ad1e0d2811c3c76957d9f29298f79d97a144
parentprofiles: mask dev-python/trio-asyncio for removal (diff)
downloadgentoo-0da148654a41181a2c2a50ec641706731b906201.tar.gz
gentoo-0da148654a41181a2c2a50ec641706731b906201.tar.bz2
gentoo-0da148654a41181a2c2a50ec641706731b906201.zip
dev-vcs/hg-git-1.0.1: version bump, python 3.11
Bug: https://bugs.gentoo.org/896950 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--dev-vcs/hg-git/Manifest3
-rw-r--r--dev-vcs/hg-git/hg-git-0.9.0.ebuild28
-rw-r--r--dev-vcs/hg-git/hg-git-1.0.1.ebuild (renamed from dev-vcs/hg-git/hg-git-0.10.2.ebuild)10
-rw-r--r--dev-vcs/hg-git/metadata.xml1
4 files changed, 6 insertions, 36 deletions
diff --git a/dev-vcs/hg-git/Manifest b/dev-vcs/hg-git/Manifest
index 39d3b785949d..2d73c76f0265 100644
--- a/dev-vcs/hg-git/Manifest
+++ b/dev-vcs/hg-git/Manifest
@@ -1,3 +1,2 @@
-DIST hg-git-0.10.2.tar.bz2 146423 BLAKE2B 7a8a24bbbcd9e46b4a8e58028baed5638e124dd7d1eacdae4031c74b1ed8bde916142a3d8df6ab74268e98669b7683aa1a9c77c780a74b1d95f102ab71ea11b2 SHA512 232bbefc88e989a771b364cc80a19e6a631b40248ac747a58e2cac2705c06a2547c711863726d69ef16d34e095c5743a2c2dba2c7f50f12b64c5ee8830453bb3
DIST hg-git-0.10.3.tar.bz2 146867 BLAKE2B cad4103cbb517c7126787fcfd5c6a9d20b814048e8277eddd1f398bb4e040cdf61d1a83ffb1a121ca62c9f038124049864c9d792ec500fd15614e7a1e2c70084 SHA512 61122084d89b62faaabfc93a8b3ef346c1c34ac3a4eea927f3f32a50490ce537333fb9e19452c2a02e172c216095d6a9db83f79d1f3ecb8afc7ae4cd554e0abc
-DIST hg-git-0.9.0.tar.bz2 129138 BLAKE2B a3758d3ff4daae98bccb71ac5471418b191596d7605c5fe867fde230a8deaacb3097b7f5f6f34ee55ba871a850c1c6f7cb6c1e9c05e388419136aecd66b775ea SHA512 03982292f042b9b48f58eeb04413f563b35fa8be1c31ca27825db8fbf293e4dfcb4bb62b6f504d82438a11c967496fb9bbd6aff5d77ae7eefdeb7747c53fcb82
+DIST hg-git-1.0.1.tar.bz2 167257 BLAKE2B c391c251749ae5216082ddb4499570d62bf2e6e870e9fa0370e6f96ea61502bff993f23864ea3b0a0d3f91df2123868e217e63c7a40db08bbbe2e12c58fd0e5f SHA512 64fe0af5453b7b3a0003da979978e1eeec8cd0887337400aea6172b7267fc8a015eae0eb93d24db3e4aaa9c62342a1fc47dd30fbd8472072527dc7ee052d73d3
diff --git a/dev-vcs/hg-git/hg-git-0.9.0.ebuild b/dev-vcs/hg-git/hg-git-0.9.0.ebuild
deleted file mode 100644
index d5d4f0f0a218..000000000000
--- a/dev-vcs/hg-git/hg-git-0.9.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_9 )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-MY_PV=${PV/_rc/a}
-DESCRIPTION="push to and pull from a Git repository using Mercurial"
-HOMEPAGE="https://hg-git.github.io https://pypi.org/project/hg-git/"
-SRC_URI="https://foss.heptapod.net/mercurial/hg-git/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="
- >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.19.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/dev-vcs/hg-git/hg-git-0.10.2.ebuild b/dev-vcs/hg-git/hg-git-1.0.1.ebuild
index 3d121966a3f6..d2776a0be124 100644
--- a/dev-vcs/hg-git/hg-git-0.10.2.ebuild
+++ b/dev-vcs/hg-git/hg-git-1.0.1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_9 )
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -17,11 +18,8 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos
IUSE=""
RDEPEND="
- >=dev-vcs/mercurial-4.3[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.19.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-vcs/mercurial-5.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
"
S="${WORKDIR}/${PN}-${MY_PV}"
diff --git a/dev-vcs/hg-git/metadata.xml b/dev-vcs/hg-git/metadata.xml
index 3289489d4abd..92e597af09ba 100644
--- a/dev-vcs/hg-git/metadata.xml
+++ b/dev-vcs/hg-git/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">hg-git</remote-id>
+ <remote-id type="heptapod">mercurial/hg-git</remote-id>
</upstream>
</pkgmetadata>