summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 01:21:33 +0000
committerSam James <sam@gentoo.org>2023-12-28 01:21:56 +0000
commit0da3af137bae14fe5bec63eda205819e6cbcdf43 (patch)
treef0f75d430f49aa541cc4a7ff16f5cad95dff6f61
parentmail-client/clawsker: add 1.3.8 (diff)
downloadgentoo-0da3af137bae14fe5bec63eda205819e6cbcdf43.tar.gz
gentoo-0da3af137bae14fe5bec63eda205819e6cbcdf43.tar.bz2
gentoo-0da3af137bae14fe5bec63eda205819e6cbcdf43.zip
app-portage/elt-patches: add 20231228
Closes: https://bugs.gentoo.org/650876 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20231228.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index e7c3087e8d21..b4bc5b9e97b7 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1,2 +1,3 @@
DIST elt-patches-20220831.tar.xz 41696 BLAKE2B c328faac2bc837fff5b9ec7dd2a891d3ab08ee30fb38d838fa6aeebbb832eb30db1f3d3b05e64c14f9cef27a21516cb6d960d7afe2314f37e25a0f77ef5d2862 SHA512 3cced1f515533ce65cef42a3c697ad0686a6c41a1b734c4558690cbdee4ebe60214b3d7f8dbb81974fc100a6882d83599f2dc77c206d9beea2449b2614319d1c
DIST elt-patches-20221210.tar.xz 42080 BLAKE2B abcdae6dedac89bd913d6809d335c13cd59b675c4b68198925bf758013e988a9bf82e9f6ccc3a70ac1c49775bb7579addda6c0bb7ea4ceea3c4b8e4acf0d65ea SHA512 3dad3c0be8d69de731bb10d5a6007539c2966f8a370a3dee27faf9655a38e39f272a9059cd98c8b6f32c2495143667f8b28a6a3425f22c0c5421f3969b417cf7
+DIST elt-patches-20231228.tar.xz 42512 BLAKE2B 00d9e9ee06da0c6d218c3af79aeb171e78aee75a2e2d586746ecc10c1e0083b317e3c5f27c923f982557e075e39210775203d25c162e34b1698542a6c1d8c1c1 SHA512 e0278fe7776dfcb6e7e869da95dbb9a65b78efc08298a7c03c16953c0f1fcff34e0ef6533dbb7fd3c60297ed85c20eb0ca89a01d74d2f1e9c6f723341c867108
diff --git a/app-portage/elt-patches/elt-patches-20231228.ebuild b/app-portage/elt-patches/elt-patches-20231228.ebuild
new file mode 100644
index 000000000000..b1667bd39ced
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20231228.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}