summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-30 21:05:28 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-11-01 22:55:05 +0100
commit0db2ec3d97452fece7e383d75014bfb71e279289 (patch)
tree7c470f9a2ea4f2bca6971ee2e516f12bed097e01
parentnet-print/ink: drop 0.5.2 (diff)
downloadgentoo-0db2ec3d.tar.gz
gentoo-0db2ec3d.tar.bz2
gentoo-0db2ec3d.zip
net-vpn/iodine: Port to EAPI 8
Closes: https://bugs.gentoo.org/819261 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-vpn/iodine/iodine-0.7.0-r3.ebuild (renamed from net-vpn/iodine/iodine-0.7.0-r2.ebuild)24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-vpn/iodine/iodine-0.7.0-r2.ebuild b/net-vpn/iodine/iodine-0.7.0-r3.ebuild
index 1309208900ab..0c944c2eeea1 100644
--- a/net-vpn/iodine/iodine-0.7.0-r2.ebuild
+++ b/net-vpn/iodine/iodine-0.7.0-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit linux-info epatch toolchain-funcs
+inherit linux-info toolchain-funcs
DESCRIPTION="IP over DNS tunnel"
HOMEPAGE="http://code.kryo.se/iodine/"
@@ -21,9 +21,13 @@ RDEPEND="sys-libs/zlib"
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
+PATCHES=(
+ "${FILESDIR}"/${P}-TestMessage.patch
+ "${FILESDIR}"/${P}-new-systemd.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-TestMessage.patch
- epatch "${FILESDIR}"/${P}-new-systemd.patch
+ default
sed -e '/^\s@echo \(CC\|LD\)/d' \
-e 's:^\(\s\)@:\1:' \
@@ -32,18 +36,12 @@ src_prepare() {
tc-export CC
}
-src_compile() {
- #shipped ./Makefiles doesn't pass -j<n> to submake
- emake -C src TARGETOS=Linux all
-}
-
src_install() {
- #don't re-run submake
+ # Don't re-run submake
sed -e '/^install:/s: all: :' \
-i Makefile || die
- emake prefix="${EPREFIX}"usr DESTDIR="${D}" install
-
- dodoc CHANGELOG README TODO
+ emake prefix="${EPREFIX}"/usr DESTDIR="${D}" install
+ einstalldocs
newinitd "${FILESDIR}"/iodined-1.init iodined
newconfd "${FILESDIR}"/iodined.conf iodined