summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-08 12:59:44 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-08 12:59:52 +0100
commit0dc53bf2e8d10a09a892b5427009412ced1d65b0 (patch)
tree7aadf6c4d420b0afef460efbd88ea9ff5301666e
parentcommon-lisp-common.eclass: Reorders metatada. Adds BLURB (diff)
downloadgentoo-0dc53bf2.tar.gz
gentoo-0dc53bf2.tar.bz2
gentoo-0dc53bf2.zip
dev-lang/ghc: add check for disk space requirement, bug #611866
Reported-by: Mike Limansky Bug: https://bugs.gentoo.org/611866 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-lang/ghc/ghc-8.0.2.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/dev-lang/ghc/ghc-8.0.2.ebuild b/dev-lang/ghc/ghc-8.0.2.ebuild
index 61c62ccf6fae..4ba077cf90b9 100644
--- a/dev-lang/ghc/ghc-8.0.2.ebuild
+++ b/dev-lang/ghc/ghc-8.0.2.ebuild
@@ -16,7 +16,7 @@ fi
inherit autotools bash-completion-r1 eutils flag-o-matic ghc-package
inherit multilib pax-utils toolchain-funcs versionator prefix
-
+inherit check-reqs
DESCRIPTION="The Glasgow Haskell Compiler"
HOMEPAGE="http://www.haskell.org/ghc/"
@@ -327,7 +327,21 @@ relocate_ghc() {
rm "$gp_back"
}
+pkg_pretend() {
+ # These are pessimistic values (slightly bigger than worst-case)
+ # Worst case is UNREG USE=profile ia64. See bug #611866 for some
+ # numbers on various arches.
+ CHECKREQS_DISK_BUILD=8G
+ CHECKREQS_DISK_USR=2G
+ # USE=binary roughly takes
+ use binary && CHECKREQS_DISK_BUILD=4G
+
+ check-reqs_pkg_pretend
+}
+
pkg_setup() {
+ check-reqs_pkg_setup
+
# quiet portage about prebuilt binaries
use binary && QA_PREBUILT="*"