summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-30 18:00:58 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-30 18:01:45 -0400
commit0dd0dbedfd0b5366161075e56e5a32f67991288f (patch)
treed33383fb311c48b351ab01dcbb9080c1476a1ae9
parentsys-cluster/vzctl: port to EAPI 7, drop {eutils, base}.eclass, add optfeature (diff)
downloadgentoo-0dd0dbed.tar.gz
gentoo-0dd0dbed.tar.bz2
gentoo-0dd0dbed.zip
media-libs/waffle: Drop old versions
Bug: https://bugs.gentoo.org/768021 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/waffle/Manifest2
-rw-r--r--media-libs/waffle/files/waffle-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch87
-rw-r--r--media-libs/waffle/waffle-1.6.1-r1.ebuild68
-rw-r--r--media-libs/waffle/waffle-1.6.2.ebuild71
4 files changed, 0 insertions, 228 deletions
diff --git a/media-libs/waffle/Manifest b/media-libs/waffle/Manifest
index 648aa7b92f7d..fccd4b6aa37e 100644
--- a/media-libs/waffle/Manifest
+++ b/media-libs/waffle/Manifest
@@ -1,3 +1 @@
-DIST waffle-1.6.1.tar.xz 227152 BLAKE2B 360782636809fa3716589e5c3f2d365ce2a916f3da4dde7ec271ce7e142f94160388f9ae12f1ef0ea79890f45eba9d6ef536e12861ee44cbd88282e3c4f01f52 SHA512 1d5839d517d1067efea163ffd76c05f32f30c3ef0f42dfa1b3a9830d4377829cce368d28889ec5a3be639a5e81db2fb4833d98eafc5ffa5e27578ff11977258f
-DIST waffle-v1.6.2.tar.bz2 259740 BLAKE2B 62708dcda7800d2728ea708f88af5e9c3ff5bbeeef653d064c457ebf86620f67d8dfcd934425810ffb66a452814337e3ed13b6f3e8a4d420363a0b66ceeaf2cf SHA512 2b1e153277366731cb5cb3790c6ae1b884efa8e5e0d5a9499a218f1a902370a066e3253f9922297314943aa751596f70a33faff10c2e480ccc1ceace93ccecbf
DIST waffle-v1.7.0.tar.bz2 302120 BLAKE2B 8ebfc78182ff86447d88d92edd6452dae28c1515de5f9639c402203bfb5a135bc493040941420161690a4812a202552266bceb89eee948d0c7aeae55d5b8d3d5 SHA512 ee7b8419e309387fa6d610174ba5dddda97525cef41c9600772b902eddfc4570e940437596d7fb50ee9dc2f5945e723236b61463975d2b9cc0faa150696d24c2
diff --git a/media-libs/waffle/files/waffle-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch b/media-libs/waffle/files/waffle-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch
deleted file mode 100644
index ef31275de08e..000000000000
--- a/media-libs/waffle/files/waffle-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From b71cfa674db5828a2be04a42ce9996d6677629ee Mon Sep 17 00:00:00 2001
-From: Dylan Baker <dylan@pnwbakers.com>
-Date: Fri, 7 Jun 2019 15:36:09 -0700
-Subject: [PATCH] meson: Generate cmake config and version files if meson is
- new enough
-
-Meson 0.50.0 added a module similar to the pkg-config module for
-generating cmake config files. Since the CMake build system provides
-these the meson build system should as well.
-
-v2: - Bump version to 0.50 instead of incorrect 0.49
-v3: - remove TODO comment that this fixes
- - Add a definition of set_and_check for meson-generated Config
- files.
-
-Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
----
- cmake/Modules/WaffleConfig.cmake.in | 10 ++++++++++
- meson.build | 2 --
- src/waffle/meson.build | 20 ++++++++++++++++++++
- 3 files changed, 30 insertions(+), 2 deletions(-)
-
-diff --git a/cmake/Modules/WaffleConfig.cmake.in b/cmake/Modules/WaffleConfig.cmake.in
-index b60b470..4e19755 100644
---- a/cmake/Modules/WaffleConfig.cmake.in
-+++ b/cmake/Modules/WaffleConfig.cmake.in
-@@ -7,6 +7,16 @@
-
- @PACKAGE_INIT@
-
-+# This should only be used for meson
-+if (NOT DEFINED set_and_check)
-+ macro(set_and_check _var _file)
-+ set(${_var} "${_file}")
-+ if(NOT EXISTS "${_file}")
-+ message(FATAL_ERROR "File or directory ${_file} referenced by variable ${_var} does not exist !")
-+ endif()
-+ endmacro()
-+endif()
-+
- set_and_check(Waffle_INCLUDE_DIRS "@PACKAGE_CMAKE_INSTALL_INCLUDEDIR@/@waffle_libname@")
- set_and_check(Waffle_LIBRARY_DIRS "@PACKAGE_CMAKE_INSTALL_LIBDIR@")
- set(Waffle_LIBRARIES "@waffle_libname@")
-diff --git a/meson.build b/meson.build
-index 29fda22..22b7f59 100644
---- a/meson.build
-+++ b/meson.build
-@@ -231,5 +231,3 @@ endif
- if get_option('build-examples')
- subdir('examples')
- endif
--
--# TODO: CMake config file
-diff --git a/src/waffle/meson.build b/src/waffle/meson.build
-index 322df40..cd68ddf 100644
---- a/src/waffle/meson.build
-+++ b/src/waffle/meson.build
-@@ -211,6 +211,26 @@ pkg.generate(
- description : 'A library for selecting an OpenGL API and windows system at runtime.',
- )
-
-+if meson.version().version_compare('>= 0.50')
-+ cmake = import('cmake')
-+ cmake.write_basic_package_version_file(
-+ name : 'Waffle',
-+ version : meson.project_version(),
-+ compatibility : 'SameMajorVersion',
-+ )
-+
-+ cmake_conf = configuration_data()
-+ cmake_conf.set('waffle_libname', waffle_name)
-+ cmake_conf.set('PACKAGE_CMAKE_INSTALL_INCLUDEDIR', join_paths('${PACKAGE_PREFIX_DIR}', get_option('includedir')))
-+ cmake_conf.set('PACKAGE_CMAKE_INSTALL_LIBDIR', join_paths('${PACKAGE_PREFIX_DIR}', get_option('libdir')))
-+
-+ cmake.configure_package_config_file(
-+ name : 'Waffle',
-+ input : '../../cmake/Modules/WaffleConfig.cmake.in',
-+ configuration : cmake_conf,
-+ )
-+endif
-+
- if get_option('build-tests')
- if get_option('default_library') == 'shared'
- # The unit tests need to poke at internals of the library, but with a
---
-2.24.1
-
diff --git a/media-libs/waffle/waffle-1.6.1-r1.ebuild b/media-libs/waffle/waffle-1.6.1-r1.ebuild
deleted file mode 100644
index 6bd3d6db7455..000000000000
--- a/media-libs/waffle/waffle-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
- GIT_ECLASS="git-r3"
-else
- SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/raw/website/files/release/${P}/${P}.tar.xz"
- KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
-fi
-inherit meson multilib-minimal ${GIT_ECLASS}
-
-DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
-HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="doc +egl +gbm wayland X"
-RESTRICT="test" # gl_basic tests don't work when run from portage
-
-RDEPEND="
- >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
- wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
-"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xml-dtd:4.2
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/wflinfo$(get_exeext)
-)
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_feature X glx)
- $(meson_feature wayland)
- $(meson_feature X x11_egl)
- $(meson_feature gbm)
- $(meson_feature egl surfaceless_egl)
- -Dbuild-manpages=true
- -Dbuild-tests=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-
- ! use doc && rm -rf "${D}"/usr/share/doc/waffle1
-}
diff --git a/media-libs/waffle/waffle-1.6.2.ebuild b/media-libs/waffle/waffle-1.6.2.ebuild
deleted file mode 100644
index a1d9e8bbbf26..000000000000
--- a/media-libs/waffle/waffle-1.6.2.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/${PN}"
- GIT_ECLASS="git-r3"
-else
- SRC_URI="https://gitlab.freedesktop.org/mesa/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86"
- S="${WORKDIR}"/${PN}-v${PV}
-fi
-inherit meson multilib-minimal ${GIT_ECLASS}
-
-DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
-HOMEPAGE="http://www.waffle-gl.org/ https://gitlab.freedesktop.org/mesa/waffle"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="doc +egl +gbm wayland X"
-RESTRICT="test" # gl_basic tests don't work when run from portage
-
-RDEPEND="
- >=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
- wayland? ( >=dev-libs/wayland-1.10[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- >=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
-"
-BDEPEND="
- dev-libs/libxslt
- app-text/docbook-xml-dtd:4.2
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-meson-Generate-cmake-config-and-version-files-if-mes.patch
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/wflinfo$(get_exeext)
-)
-
-multilib_src_configure() {
- local emesonargs=(
- $(meson_feature X glx)
- $(meson_feature wayland)
- $(meson_feature X x11_egl)
- $(meson_feature gbm)
- $(meson_feature egl surfaceless_egl)
- -Dbuild-manpages=$(multilib_is_native_abi && echo true || echo false)
- -Dbuild-tests=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_install() {
- meson_src_install
-
- ! use doc && rm -rf \
- "${D}"/usr/share/doc/waffle1 \
- "${D}"/usr/share/man/man{3,7}
-}