summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-03 04:49:42 +0000
committerSam James <sam@gentoo.org>2021-12-03 04:50:27 +0000
commit0de4fa6c810cfc668e2dcefd12a940e724bea791 (patch)
tree53f8e1bba90a14a8b37283e8a328d0c6c0a95245
parentdev-libs/pkcs11-helper: adapt for OpenSSL bindist changes (diff)
downloadgentoo-0de4fa6c810cfc668e2dcefd12a940e724bea791.tar.gz
gentoo-0de4fa6c810cfc668e2dcefd12a940e724bea791.tar.bz2
gentoo-0de4fa6c810cfc668e2dcefd12a940e724bea791.zip
dev-libs/softhsm: adapt for OpenSSL bindist changes
OpenSSL no longer has a bindist flag. Bug: https://bugs.gentoo.org/762850 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/softhsm/softhsm-2.6.1-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/softhsm/softhsm-2.6.1-r2.ebuild b/dev-libs/softhsm/softhsm-2.6.1-r2.ebuild
new file mode 100644
index 000000000000..6a7ef28681b0
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-2.6.1-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="https://www.opendnssec.org/"
+SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gost migration-tool test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ migration-tool? ( dev-db/sqlite:3= )
+ dev-libs/openssl:=
+ !~dev-libs/softhsm-2.0.0:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gcc:=[cxx]
+ virtual/pkgconfig
+ test? ( dev-util/cppunit )
+"
+
+DOCS=( NEWS README.md )
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-crypto-backend=openssl \
+ --disable-p11-kit \
+ --localstatedir="${EPREFIX}/var" \
+ --enable-ecc \
+ $(use_enable gost) \
+ $(use_with migration-tool migrate)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ keepdir /var/lib/softhsm/tokens
+}