summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-14 12:17:55 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-14 12:18:17 +0200
commit0dfa14515d5e57814f0f981dbdefdfb8cb271112 (patch)
tree6d281404d0c62b3ddbfe955966e9aa3e270ab5b0
parentdev-libs/ucommon: Drop old (diff)
downloadgentoo-0dfa14515d5e57814f0f981dbdefdfb8cb271112.tar.gz
gentoo-0dfa14515d5e57814f0f981dbdefdfb8cb271112.tar.bz2
gentoo-0dfa14515d5e57814f0f981dbdefdfb8cb271112.zip
net-libs/ccrtp: Fix deps
Closes: https://bugs.gentoo.org/590924 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-libs/ccrtp/ccrtp-2.1.2.ebuild30
1 files changed, 10 insertions, 20 deletions
diff --git a/net-libs/ccrtp/ccrtp-2.1.2.ebuild b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
index 02cf6d4014df..0ed701175c1c 100644
--- a/net-libs/ccrtp/ccrtp-2.1.2.ebuild
+++ b/net-libs/ccrtp/ccrtp-2.1.2.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils multilib
+EAPI=7
DESCRIPTION="GNU ccRTP - Implementation of the IETF real-time transport protocol"
HOMEPAGE="https://www.gnu.org/software/ccrtp/"
@@ -13,31 +12,22 @@ LICENSE="GPL-2"
IUSE="doc"
SLOT="0/2"
-RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
+RDEPEND="
+ >=dev-cpp/commoncpp2-1.3.0:0=
dev-libs/libgcrypt:0=
- >=dev-libs/ucommon-5.0.0:="
+ >=dev-libs/ucommon-6.2.2:=
+"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
src_configure() {
econf --disable-static
}
src_install() {
+ use doc && HTML_DOCS="doc/html/*"
default
- prune_libtool_files
- use doc && dohtml -r doc/html/*
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
- elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
- fi
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
- elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
- fi
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
- elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
- fi
+ find "${D}" -name '*.la' -delete || die
}