summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 09:35:13 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-09 15:58:26 +0100
commit0e2a5a1e036753526b6bff0f34dfd9d54ef1bc15 (patch)
treedfbe91f228989dcd440ac271d71045f0e69f9919
parentsys-devel/llvmgold: Bump to 6.0.0 final (diff)
downloadgentoo-0e2a5a1e036753526b6bff0f34dfd9d54ef1bc15.tar.gz
gentoo-0e2a5a1e036753526b6bff0f34dfd9d54ef1bc15.tar.bz2
gentoo-0e2a5a1e036753526b6bff0f34dfd9d54ef1bc15.zip
dev-ml/llvm-ocaml: Bump to 6.0.0 final
-rw-r--r--dev-ml/llvm-ocaml/Manifest2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-6.0.0.ebuild (renamed from dev-ml/llvm-ocaml/llvm-ocaml-6.0.0_rc3.ebuild)8
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/Manifest b/dev-ml/llvm-ocaml/Manifest
index ff258ef36659..228e237b8c91 100644
--- a/dev-ml/llvm-ocaml/Manifest
+++ b/dev-ml/llvm-ocaml/Manifest
@@ -1,3 +1,3 @@
DIST llvm-4.0.1.src.tar.xz 21065652 BLAKE2B 6327eed2d1feb108440f22d2581d1ff86c10a10c29793538d8d899c7e2dc83d3f7b147d3fd4bcce2bd2bf57c071b08c624aeafe40a3e7a3914506e7751727e6c SHA512 16adc39b34ddb628f81b171119a8e2a0e9138b25011e803ef0b688e2fbea116fc4953d3a1b61b90a98a75e33619f81566b7cb06a9a2ea4d04ac5e0eb303a2d1d
DIST llvm-5.0.1.src.tar.xz 23428720 BLAKE2B 3db4d33df21018d17eef0042c0d8d82a8412bd5daa99cfb5405a6ec83c5774178fa76b220e8731c2a9a64dabf898aa90fe29c685327bd63a4f078e8e94a9a77e SHA512 bee1d45fca15ce725b1f2b1339b13eb6f750a3a321cfd099075477ec25835a8ca55b5366172c4aad46592dfd8afe372349ecf264f581463d017f9cee2d63c1cb
-DIST llvm-6.0.0rc3.src.tar.xz 25295644 BLAKE2B 5832b3daefbbf043caaac38791eb95a321cbee82bfa12710e332ea14b8ee6d1fe81c4fcea19cdbabd24b89e338575e367bab481c47eb6a6bfbd6a926f02fe5b2 SHA512 9932debae40ced0137c1e1675fb91b996326c7eed1b67d1280bd2b0f5bd62e15d47c87d0e215fe29680cb628853c6a446587623a6f3312ce42612b2ac865e3cd
+DIST llvm-6.0.0.src.tar.xz 25296048 BLAKE2B 7ea90bb63d6f26cfbc1c1ed2f243b0fcd8ad2ceb7963cf768d262cd55e9a0c71a9cfdea0333fb220faacf4540d924d2512532774dcfb52b52490ad74e38c09e0 SHA512 a71fdd5ddc46f01327ad891cfcc198febdbe10769c57f14d8a4fb7d514621ee4080e1a641200d3353c16a16731d390270499ec6cd3dc98fadc570f3eb6b52b8c
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.0_rc3.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.0.ebuild
index ff74f2cf3406..0e64a225bb7b 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.0_rc3.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.0.ebuild
@@ -8,12 +8,12 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils llvm python-any-r1
+inherit cmake-utils llvm multiprocessing python-any-r1
MY_P=llvm-${PV/_/}.src
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-SRC_URI="http://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -23,7 +23,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="UoI-NCSA"
SLOT="0/${PV}"
-KEYWORDS=""
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
RESTRICT="!test? ( test )"
@@ -88,7 +88,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844