summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 00:49:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 00:51:42 +0100
commit0e2e1aa9cb3268b83c3d046fd7050b1b1a2e5137 (patch)
tree7360dcbf0b515949d068ef6022e25ccb584d5683
parent*/*: Switch Perlovka's ebuilds to cmake.eclass (diff)
downloadgentoo-0e2e1aa9cb3268b83c3d046fd7050b1b1a2e5137.tar.gz
gentoo-0e2e1aa9cb3268b83c3d046fd7050b1b1a2e5137.tar.bz2
gentoo-0e2e1aa9cb3268b83c3d046fd7050b1b1a2e5137.zip
app-text/sigil: Switch to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-text/sigil/sigil-0.9.16.ebuild8
-rw-r--r--app-text/sigil/sigil-0.9.18.ebuild6
-rw-r--r--app-text/sigil/sigil-1.0.0.ebuild6
3 files changed, 10 insertions, 10 deletions
diff --git a/app-text/sigil/sigil-0.9.16.ebuild b/app-text/sigil/sigil-0.9.16.ebuild
index a06e4addd82e..a712ce00178e 100644
--- a/app-text/sigil/sigil-0.9.16.ebuild
+++ b/app-text/sigil/sigil-0.9.16.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="tk"
-inherit cmake-utils python-single-r1 readme.gentoo-r1 xdg-utils
+inherit cmake python-single-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
HOMEPAGE="https://sigil-ebook.com/"
@@ -72,7 +72,7 @@ for best performance with Sigil."
src_prepare() {
# bundled is a exact copy of the package, and upstream plan to switch soon
rm -r src/Resource_Files/plugin_launchers/python/css_parser/ || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -87,11 +87,11 @@ src_configure() {
)
use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_fix_shebang "${ED}"/usr/share/sigil/
python_optimize "${ED}"/usr/share/sigil/
DISABLE_AUTOFORMATTING=true readme.gentoo_create_doc
diff --git a/app-text/sigil/sigil-0.9.18.ebuild b/app-text/sigil/sigil-0.9.18.ebuild
index 119ad45230c6..ee2155ae5c35 100644
--- a/app-text/sigil/sigil-0.9.18.ebuild
+++ b/app-text/sigil/sigil-0.9.18.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="tk"
-inherit cmake-utils python-single-r1 readme.gentoo-r1 xdg-utils
+inherit cmake python-single-r1 readme.gentoo-r1 xdg-utils
DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
@@ -80,11 +80,11 @@ src_configure() {
)
use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_fix_shebang "${ED}"/usr/share/sigil/
python_optimize "${ED}"/usr/share/sigil/
DISABLE_AUTOFORMATTING=true readme.gentoo_create_doc
diff --git a/app-text/sigil/sigil-1.0.0.ebuild b/app-text/sigil/sigil-1.0.0.ebuild
index dc09ca8c6b51..0d5c548e6440 100644
--- a/app-text/sigil/sigil-1.0.0.ebuild
+++ b/app-text/sigil/sigil-1.0.0.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="tk"
-inherit cmake-utils python-single-r1 xdg-utils
+inherit cmake python-single-r1 xdg-utils
DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
@@ -65,11 +65,11 @@ src_configure() {
)
use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
python_fix_shebang "${ED}"/usr/share/sigil/
python_optimize "${ED}"/usr/share/sigil/
}