summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-02-15 11:40:53 -0800
committerMatt Turner <mattst88@gentoo.org>2018-02-15 11:41:20 -0800
commit0e485e2fcf88a9741484e76d529843665c61719c (patch)
tree785237d8df64b3e81752f828837da1250f747382
parentdev-php/PEAR-PEAR_PackageFileManager2: Drop minimal USE (diff)
downloadgentoo-0e485e2fcf88a9741484e76d529843665c61719c.tar.gz
gentoo-0e485e2fcf88a9741484e76d529843665c61719c.tar.bz2
gentoo-0e485e2fcf88a9741484e76d529843665c61719c.zip
x11-drivers/xf86-video-vesa: Version bump to 2.4.0
-rw-r--r--x11-drivers/xf86-video-vesa/Manifest1
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-vesa/Manifest b/x11-drivers/xf86-video-vesa/Manifest
index 7bf3006a5946..ea31dcf28a99 100644
--- a/x11-drivers/xf86-video-vesa/Manifest
+++ b/x11-drivers/xf86-video-vesa/Manifest
@@ -1,2 +1,3 @@
DIST xf86-video-vesa-2.3.3.tar.bz2 300571 BLAKE2B 9c7b5ef966234de7ca792925c2d88766df5c75bc0085dc1aad9fe11845e37f7a2214b028f546c88283579a54d476766d57e4acb4942c5a578159c65199a2bf68 SHA512 1e3768e757e889bb8707ce76cc6f54eb3beaf7d5b34750a0e7262612ae300e4cd42985b7cbcd72462b14c8d73945a22cec70ca6a52017491de41715d2ecbaca8
DIST xf86-video-vesa-2.3.4.tar.bz2 285675 BLAKE2B 88c66b5bc3fbeb74867711e0bbda91f9f693d16a5080790c4e93ed203784ab730563053a2822e92fd2287e1fa59014f7a0a1e1c497e750a2e9c3ef84537f0bde SHA512 5a01c295a03f367281f49bb186a003a91da3aa4cff7c37ef3fb83889b595f641745899c62e4c0954a1daf4b18bd0e1bcbbe1b87d2863d1ce71feffa1744e892d
+DIST xf86-video-vesa-2.4.0.tar.bz2 324599 BLAKE2B ddaa7a54d439b1afb1152e15e0d436cade79c51a61e78837a066e3e0c04d4a2ea6b079e68eca917e618aae125ed4eab7734009a337018460e771265b8daef443 SHA512 4af5c0a7fd64eba503980198cf510688dff2f33482ceac446455d97255dcc828613387ac57828eb6dce080cb15a8644a2b2e278bf356705fdeaea873ab07c2de
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild
new file mode 100644
index 000000000000..95de4a3db131
--- /dev/null
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-info xorg-2
+
+DESCRIPTION="Generic VESA video driver"
+KEYWORDS="-* ~alpha ~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.6
+ >=x11-libs/libpciaccess-0.12.901"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}