summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-06 17:42:21 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-06 23:46:47 +0100
commit0e511dfe082cf36accc8e0793a97e027f8eb2f31 (patch)
tree635901cf9b8d42f1000bde317e5e55db0aa14b93
parentx11-misc/ftmenu: EAPI bump 2 -> 6 (diff)
downloadgentoo-0e511dfe082cf36accc8e0793a97e027f8eb2f31.tar.gz
gentoo-0e511dfe082cf36accc8e0793a97e027f8eb2f31.tar.bz2
gentoo-0e511dfe082cf36accc8e0793a97e027f8eb2f31.zip
x11-misc/habak: EAPI bump 2 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3848
-rw-r--r--x11-misc/habak/habak-0.2.5-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/habak/habak-0.2.5-r2.ebuild b/x11-misc/habak/habak-0.2.5-r2.ebuild
new file mode 100644
index 000000000000..ab1bd975368c
--- /dev/null
+++ b/x11-misc/habak/habak-0.2.5-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple but powerful tool to set desktop wallpaper"
+HOMEPAGE="http://home.gna.org/fvwm-crystal/"
+SRC_URI="http://download.gna.org/fvwm-crystal/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+# Skip into the src directory so we avoid a recursive make call that
+# is going to break parallel make.
+S="${WORKDIR}/${P}/src"
+
+DOCS=( ChangeLog README TODO "${FILESDIR}"/README.en )
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/(LDFLAGS)/s:$: -lImlib2 -lm -lX11:' \
+ -e 's:gcc:$(CC):' \
+ "${S}"/Makefile || die "Makefile fixing failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ cd "${WORKDIR}/${P}" || die
+ einstalldocs
+}