summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2020-10-06 06:55:13 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2020-10-06 07:06:23 +0200
commit0e5747d723a08bdf6508086f644052aac31cce87 (patch)
treee85d1c68462d1de7eb2f8d24807eb3bdc38b76e3
parentdev-util/dwarves: Switch from eclass cmake-utils to cmake (diff)
downloadgentoo-0e5747d7.tar.gz
gentoo-0e5747d7.tar.bz2
gentoo-0e5747d7.zip
dev-util/dwarves: Bumped version to 1.18
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthias Schwarzott <zzam@gentoo.org>
-rw-r--r--dev-util/dwarves/Manifest1
-rw-r--r--dev-util/dwarves/dwarves-1.18.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/dwarves/Manifest b/dev-util/dwarves/Manifest
index d9e366842351..31948b930318 100644
--- a/dev-util/dwarves/Manifest
+++ b/dev-util/dwarves/Manifest
@@ -1 +1,2 @@
DIST dwarves-1.17.tar.xz 309028 BLAKE2B 600d095359fa1ef208cc83655761505a07512faf9957144cc5fdd9e69bef98be3afc8b29a4c13aa0246aa43fdc9b4906de95f37c86fc6790ece52a79e3b13695 SHA512 8916ea24316efe1eb322d045fb2d81c230905f2fe33942eac641e9e0311f33a3bcf55be454eac32781799c255303bafacd8f1bd1b3ec08f0dae4d5f38d8186ba
+DIST dwarves-1.18.tar.xz 324912 BLAKE2B bdce2903608a1229e2fc7e8a01bc41249a17a1a003fc3616910959fc43b430569cd737a220edfab2473485cd2dc0519b4add0e0e3a690e51ad35c4fa082752a5 SHA512 01647607ce0f4dfceb464367f2dd8a432f33eb5d0e003b6bbb07b38bd992a2992844309b04aee2a0388658c41d8b2059d03064c6e450fe7c347c5bca445d7938
diff --git a/dev-util/dwarves/dwarves-1.18.ebuild b/dev-util/dwarves/dwarves-1.18.ebuild
new file mode 100644
index 000000000000..063b96dc5e59
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit multilib cmake python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="https://git.kernel.org/cgit/devel/pahole/pahole.git/"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.178
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.xz"
+else
+ SRC_URI="https://dev.gentoo.org/~zzam/${PN}/${P}.tar.xz"
+fi
+
+DOCS=( README README.ctracer NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-python-import.patch
+)
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake_src_install
+}