summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 21:54:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 22:33:27 +0200
commit0e5be946bc5905314d28653a83dc64f782a8fefd (patch)
tree7dd32b364a9e0641c5c6290753f91a5e40a7620e
parentdev-python/nbconvert: Bump to 6.0.4 (diff)
downloadgentoo-0e5be946bc5905314d28653a83dc64f782a8fefd.tar.gz
gentoo-0e5be946bc5905314d28653a83dc64f782a8fefd.tar.bz2
gentoo-0e5be946bc5905314d28653a83dc64f782a8fefd.zip
dev-python/terminado: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/terminado/Manifest1
-rw-r--r--dev-python/terminado/terminado-0.9.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/terminado/Manifest b/dev-python/terminado/Manifest
index 0a9aca41af98..98a19f17809f 100644
--- a/dev-python/terminado/Manifest
+++ b/dev-python/terminado/Manifest
@@ -1,2 +1,3 @@
DIST terminado-0.8.3.tar.gz 21165 BLAKE2B ec031cb7828840a4f299aa25de0030d5b7993119fd41b71e698dd032f4fd31ea725a9b610dc53a71d480ee74b49a1d072d76555b434da4f5fee2479efa03fdec SHA512 441355cdc919b6f04b1bf1eb870f24e0bd6c7ef412e72e1747707049b1fa0d6676644e3646007f2653b3df00e1f30048d9dc40d73f0827b2bbfc0821549e140b
DIST terminado-0.9.0.tar.gz 10363 BLAKE2B d984d290f95be196693fa50754266c44c5ddf817eec1876d573d2f254719d168f011cfa1673eca090cafb2f28738fcbcf1f4837ec80fb4438c1d1158e09b7a0b SHA512 31ec024a0ae216f08955d2a5789fd63f03021b1a52a6a1b02a5b2e7165c99a386c77e85b4a632dfaa2608bc6ceaaaad1b8757b6de6a9f5793134cfc57f943aff
+DIST terminado-0.9.1.tar.gz 12335 BLAKE2B 7f4d7794b8bccb3d7eafd5ab35130521633c391d19fcc93e02c24f3937c7f186e786d12047dde066807ee2ace3ee7db4f0607fc9c10dc976344c32398b5da23b SHA512 429d2417cfc5521ee471febae6d893764cc0f1c7024c272951a178db5e2d20ce64af499393cd020ff6b424dc8b07d69a70da5789b39b49510a5789351a6f04f4
diff --git a/dev-python/terminado/terminado-0.9.1.ebuild b/dev-python/terminado/terminado-0.9.1.ebuild
new file mode 100644
index 000000000000..8d931385692e
--- /dev/null
+++ b/dev-python/terminado/terminado-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.org/project/terminado/ https://github.com/jupyter/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:test_max_terminals:_&:' \
+ terminado/tests/basic_test.py || die
+ distutils-r1_src_prepare
+}