summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 10:12:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 10:17:05 +0200
commit0e5c2cb089c728870360973fe92a71978462062f (patch)
tree378ccd4ac80a2aafe38f870607e8c93657b03d96
parentdev-python/ruamel-yaml: Bump to 0.17.2 (diff)
downloadgentoo-0e5c2cb0.tar.gz
gentoo-0e5c2cb0.tar.bz2
gentoo-0e5c2cb0.zip
dev-python/djangorestframework: Bump to 3.12.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.12.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index e95b2a7e64bb..cc4cc8a41f20 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1 +1,2 @@
DIST django-rest-framework-3.12.2.gh.tar.gz 8856613 BLAKE2B 77d0b3bad38c7829387de752d913eb758935615213d8f8ada9422ecf25142383c1b11a1c95d5fc9f4cf7634e494119ddcb236c810e85429fa8cd4ecd1ef88132 SHA512 7c3e712897562eff14ddfa4ded6627d6b4263001e0c9a4047b92da43c0fd86e8ac9d09bb54bb87ce0d4e7743553c4733a60b18327f7e4d481cb9898593731467
+DIST django-rest-framework-3.12.4.gh.tar.gz 8856507 BLAKE2B 48150e8d966ddd169a2b58d90656efa8f9f549c9d2fdee6025254fba2a6221704fe6bcb246567c8acb963f76ea56046935d3190c7c391daf4773b100a641ba02 SHA512 406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9
diff --git a/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild b/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
new file mode 100644
index 000000000000..8530587f35df
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.12.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}