summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-02 22:11:01 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-02 22:15:38 +0300
commit0e678559d6baf268e365150c4808fbf3597e99a1 (patch)
treecd91a0c599ec2c6ac9d1eb568548ce0fb279cf46
parentdev-python/django-taggit: add 3.0.0 (diff)
downloadgentoo-0e678559.tar.gz
gentoo-0e678559.tar.bz2
gentoo-0e678559.zip
dev-python/pdm-pep517: add 0.12.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pdm-pep517/Manifest1
-rw-r--r--dev-python/pdm-pep517/pdm-pep517-0.12.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pdm-pep517/Manifest b/dev-python/pdm-pep517/Manifest
index 3d4a51949a46..a1d40f80ffa3 100644
--- a/dev-python/pdm-pep517/Manifest
+++ b/dev-python/pdm-pep517/Manifest
@@ -1 +1,2 @@
DIST pdm-pep517-0.12.3.gh.tar.gz 304242 BLAKE2B ad4beb6ab35c219e1991b585bf9ce087be3e7e957f34b1dbc9de676f7b49c3084471e2b55c634eb6fd1cf6cb88dd4161b5060a17a5ca7e5e3ae57c9610303f6e SHA512 4c0f098d5237353fea73ef62149b8177987881239cb6b1b112bd6789931acd7484c56d413f780db4f23c60f4ff3a37c6956de3e1de472fed114487925b0e3553
+DIST pdm-pep517-0.12.4.gh.tar.gz 304353 BLAKE2B ca2b18af38423f7430a40e5cced207bd4bec8d101204902c89f335c5d08131e95fe17c5af7a3ef0e654c9e2106145ef5242c9015924a2711c90dbb0d2f48128e SHA512 2007a84909147cd48e9ea6114119a63855ddf48e220f8c896d516b6bddd5a7bd62046f090d739a5069b9e06700f0318e57bd1a4b3c7531508b41540357639c5e
diff --git a/dev-python/pdm-pep517/pdm-pep517-0.12.4.ebuild b/dev-python/pdm-pep517/pdm-pep517-0.12.4.ebuild
new file mode 100644
index 000000000000..c95abf912f72
--- /dev/null
+++ b/dev-python/pdm-pep517/pdm-pep517-0.12.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A PEP 517 backend for PDM that supports PEP 621 metadata"
+HOMEPAGE="
+ https://pypi.org/project/pdm-pep517/
+ https://github.com/pdm-project/pdm-pep517/
+"
+SRC_URI="
+ https://github.com/pdm-project/pdm-pep517/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cerberus-1.3.4[${PYTHON_USEDEP}]
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-2[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-vcs/git
+ )
+"
+# setuptools are used to build C extensions
+RDEPEND+="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r pdm/pep517/_vendor || die
+ find -name '*.py' -exec sed \
+ -e 's:from pdm\.pep517\._vendor\.:from :' \
+ -e 's:from pdm\.pep517\._vendor ::' \
+ -i {} + || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ git config --global user.email "test@example.com" || die
+ git config --global user.name "Test User" || die
+ distutils-r1_src_test
+}