summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-24 08:25:14 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-24 08:25:48 -0700
commit0e6ce184e7eaa62128b58794041717cd555c74dd (patch)
treeff61134d5b79d7e8955ad3f6739dde49526cf0a5
parentsys-apps/systemd: add 255.5 (diff)
downloadgentoo-0e6ce184e7eaa62128b58794041717cd555c74dd.tar.gz
gentoo-0e6ce184e7eaa62128b58794041717cd555c74dd.tar.bz2
gentoo-0e6ce184e7eaa62128b58794041717cd555c74dd.zip
dev-python/thriftpy2: Revbump, add py312 (bug #929518)
Closes: https://bugs.gentoo.org/929518 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.20-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.20-r1.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.20-r1.ebuild
new file mode 100644
index 000000000000..a763b9df7329
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.20-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic pypi
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/857105
+ # https://github.com/Thriftpy/thriftpy2/issues/246
+ #
+ # Don't trust this to LTO
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ pushd tests >/dev/null || die
+ epytest
+ popd >/dev/null || die
+}