summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-28 10:43:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:32 +0100
commit0e6f8f0c9b54a1ed6e6c207f88a0364a9b4e21fa (patch)
tree2daac828594ba6dcb30054a087e22439db332196
parentdev-python/rosdistro: 0.6.6 (diff)
downloadgentoo-0e6f8f0c.tar.gz
gentoo-0e6f8f0c.tar.bz2
gentoo-0e6f8f0c.zip
dev-ros/cpp_common: Bump to 0.6.8.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--dev-ros/cpp_common/Manifest1
-rw-r--r--dev-ros/cpp_common/cpp_common-0.6.8.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/cpp_common/Manifest b/dev-ros/cpp_common/Manifest
index ac7b0a6fbfe3..d783d293e3e2 100644
--- a/dev-ros/cpp_common/Manifest
+++ b/dev-ros/cpp_common/Manifest
@@ -1 +1,2 @@
DIST roscpp_core-0.6.7.tar.gz 34845 BLAKE2B cdb2385069a74d670061bc2245421e31216e1c9ace5c96f83d1875ddcf460f2ad425b10db3330253e2a49f3bc415cf3c72ab885cb121c9477ae54a385893a7b8 SHA512 d93afb6e0e88bb01b13af0334a7977411fac8f89dd06fc69a32b95bab4ead05d6cb564b089ee846fe542be180f6418664f8328a6a9e753a55b34e5a0a1d61bf4
+DIST roscpp_core-0.6.8.tar.gz 35003 BLAKE2B 7b4c02652693f76326df83d17164d3268f8b0eda0ddfe8f73d286ae09d7fbb3f8f433ab92527167fb918b55c53aeaa4e26d6876dac51d9d35e0b18b185d89867 SHA512 5fa9f8714059fbc864583662cd411d64470565cc2c372a09a63708a8cc06140d2ce8b84a7025837a49f2c09c7fee5092ec42d5625de4bfd2d9410baf7821b5df
diff --git a/dev-ros/cpp_common/cpp_common-0.6.8.ebuild b/dev-ros/cpp_common/cpp_common-0.6.8.ebuild
new file mode 100644
index 000000000000..4b61973c2c53
--- /dev/null
+++ b/dev-ros/cpp_common/cpp_common-0.6.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ code for doing things that are not necessarily ROS related"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge:=
+ dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"