summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-15 01:45:02 +0100
committerSam James <sam@gentoo.org>2023-04-15 01:45:02 +0100
commit0e748c0d213d1fde1baa4cdbe01252c409d3341f (patch)
treee106af4d45e7c2b2d73fa40828c1f61fcf5c2d66
parentmedia-gfx/graphviz: Stabilize 7.1.0 arm, #904345 (diff)
downloadgentoo-0e748c0d213d1fde1baa4cdbe01252c409d3341f.tar.gz
gentoo-0e748c0d213d1fde1baa4cdbe01252c409d3341f.tar.bz2
gentoo-0e748c0d213d1fde1baa4cdbe01252c409d3341f.zip
media-sound/audacity: add partial GCC 13 fix
Closes: https://bugs.gentoo.org/899764 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/audacity/audacity-3.2.5.ebuild3
-rw-r--r--media-sound/audacity/files/audacity-3.2.5-gcc13.patch25
2 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/audacity/audacity-3.2.5.ebuild b/media-sound/audacity/audacity-3.2.5.ebuild
index 9b1ee5735698..0d2e26a3d311 100644
--- a/media-sound/audacity/audacity-3.2.5.ebuild
+++ b/media-sound/audacity/audacity-3.2.5.ebuild
@@ -122,6 +122,9 @@ PATCHES=(
# For has_networking
"${FILESDIR}/${PN}-3.2.3-remove-conan-threadpool.patch"
"${FILESDIR}/${PN}-3.2.3-allow-finding-rapidjson-pkgconfig.patch"
+
+ # GCC 13
+ "${FILESDIR}/${PN}-3.2.5-gcc13.patch"
)
src_prepare() {
diff --git a/media-sound/audacity/files/audacity-3.2.5-gcc13.patch b/media-sound/audacity/files/audacity-3.2.5-gcc13.patch
new file mode 100644
index 000000000000..265d73fd9e71
--- /dev/null
+++ b/media-sound/audacity/files/audacity-3.2.5-gcc13.patch
@@ -0,0 +1,25 @@
+https://github.com/audacity/audacity/issues/4489
+https://bugs.gentoo.org/899764
+
+--- a/lib-src/libnyquist/nyquist/nyqstk/include/Stk.h
++++ b/lib-src/libnyquist/nyquist/nyqstk/include/Stk.h
+@@ -47,6 +47,7 @@
+ #endif
+
+ #include <stddef.h>
++#include <stdint.h>
+ #include <string>
+ #include <iostream>
+ #include <sstream>
+@@ -355,10 +356,6 @@
+ typedef signed int SINT32;
+ typedef float FLOAT32;
+ typedef double FLOAT64;
+-// added by RBD
+-#ifdef __linux__
+-#define intptr_t long
+-#endif
+
+ // The default sampling rate.
+ const StkFloat SRATE = 44100.0;
+