summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:17:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:42:58 +0200
commit0e76b6d54893a4602d44af366df9a98556b32a8a (patch)
treed4f94b389b8d1c68c161aff9e1520714a4941418
parentdev-python/argh: Bump to 0.30.2 (diff)
downloadgentoo-0e76b6d5.tar.gz
gentoo-0e76b6d5.tar.bz2
gentoo-0e76b6d5.zip
dev-python/werkzeug: Bump to 3.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-3.0.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 06c55a5f5062..cb4f8167c0cb 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-2.3.7.gh.tar.gz 834304 BLAKE2B 331ffe1f7f079defbd639f391522facfd98cad704da0ed92235f111f401c40b3d06c40b2e0f5c0d0ac8d798335171870a6ce221d02810a8cf3d25f480ee7f7f8 SHA512 76daba77523f486a56f945f54b9f317589d72e36458d7dce975ae597835de8936242edd6ceafa8913d00021557a9da2acfe9619be562fe7b482858daf84dfd2f
DIST werkzeug-3.0.0.gh.tar.gz 817103 BLAKE2B d606b5c8956b69f32fd944c1a55b2ea0815f97d02665e6fa430a66a8ca64021d6f1263262971f59e5d4f69ece36053138504c81d7392edc09ca4c8337be104be SHA512 d220a38e0fbc4e5da8f705f9d53fb9a22a7ff1643cfd4ba35101cb9c814fa31b0a6f58bb1f024108ff5c3571f4b0333e58fb6c1b331f5caf44d89fac03dd5ad7
+DIST werkzeug-3.0.1.gh.tar.gz 817317 BLAKE2B 670460cf48c8d06196cd34f117758508512d310b740bd188d8ba87779abd62f514c9909e5700b34c37e382925eabe3ffd722b753b76b498aff0dc8ebe1025c8b SHA512 125a5c7680cba726149198802efa90d06c6586daeafcd0960feda637b765356f602df83af7b14996994303c52d32bc6fa044b774f42f0b8991008d1396675033
diff --git a/dev-python/werkzeug/werkzeug-3.0.1.ebuild b/dev-python/werkzeug/werkzeug-3.0.1.ebuild
new file mode 100644
index 000000000000..1e459f682aa3
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-3.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.3[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{10..11})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}