summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-10-23 09:49:59 -0400
committerCraig Andrews <candrews@gentoo.org>2018-10-23 09:50:16 -0400
commit0e8c7e48d9e427559592eca8ac51b10292f30c32 (patch)
tree1119a4ee0457deb54d66dd0c37d2d0b6ea5b8d5e
parentdev-util/electron: Drop old versions (diff)
downloadgentoo-0e8c7e48d9e427559592eca8ac51b10292f30c32.tar.gz
gentoo-0e8c7e48d9e427559592eca8ac51b10292f30c32.tar.bz2
gentoo-0e8c7e48d9e427559592eca8ac51b10292f30c32.zip
app-arch/brotli: 1.0.7 version bump
Signed-off-by: Craig Andrews <candrews@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.7.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index b18cc16a9b11..4c07a7e06d49 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -3,3 +3,4 @@ DIST brotli-1.0.3.tar.gz 23815300 BLAKE2B 9569267782a8159d290e0f1b524a985144d1ae
DIST brotli-1.0.4.tar.gz 23819000 BLAKE2B 5c0a7ed2cb7e15722c2f08dbaaaa5e74f10a03b95961d77db285fac437a489158cf8f7d43a55fac75eb5423951286accf0285e3e3471e34e35868a69dbf42f16 SHA512 7d41ad37ca0755ba9e08e7355fb031e24a53a5f6d44ff827adee6d9712765af02142cb463ef558f92449ce3b73e559cffb52315a329ab702f4c46927f993b616
DIST brotli-1.0.5.tar.gz 23825684 BLAKE2B b179f75f3e452bdd3fabbd74d9172bc0a00f797e7facf7a9061e5e81c52148297ea7dd8ab9954c3f596f59e2a96cb22ef057c4c02b1bba4ecf10db7b70e0711d SHA512 703cad94c7f250133d2cfe222f3183612c7649b184bba218907b805f423568046d42695f33acf7da95daf684be118c9d631cfa5706e5a195b611c716db4c839a
DIST brotli-1.0.6.tar.gz 23827656 BLAKE2B 8d31eb1c4119de44702f2239fba9db72f1ae81801d06e51716432ff2f8aa78259c52cbd57b8fcd005c1bc14ada81b6e47a35c5d3864bb10bb02d113e30bd321b SHA512 b9847375471de3ae815ef4bb45a29653c343fad0a891a79d5132fcdee34c85caafd82289c8b413c3ef609049f2e8c4af9f9abd1736a2408ba44544c5fefc0010
+DIST brotli-1.0.7.tar.gz 23827908 BLAKE2B b9fc554cd23c8387b648638b6f9bb2d29fa87035856d03cf284662f9281984f3bf8e40109e61155ece18673f4391bc0fff704f8ab800a2041d3ce1824478d2ae SHA512 a82362aa36d2f2094bca0b2808d9de0d57291fb3a4c29d7c0ca0a37e73087ec5ac4df299c8c363e61106fccf2fe7f58b5cf76eb97729e2696058ef43b1d3930a
diff --git a/app-arch/brotli/brotli-1.0.7.ebuild b/app-arch/brotli/brotli-1.0.7.ebuild
new file mode 100644
index 000000000000..72733671f1db
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+DISTUTILS_OPTIONAL="1"
+DISTUTILS_IN_SOURCE_BUILD="1"
+
+inherit cmake-multilib distutils-r1 eapi7-ver
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli"
+
+SLOT="0/$(ver_cut 1)"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ use python && distutils-r1_src_prepare
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake-utils_src_configure
+}
+src_configure() {
+ cmake-multilib_src_configure
+ use python && distutils-r1_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+}
+src_compile() {
+ cmake-multilib_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test(){
+ esetup.py test || die
+}
+
+multilib_src_test() {
+ cmake-utils_src_test
+}
+src_test() {
+ cmake-multilib_src_test
+ use python && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+}
+multilib_src_install_all() {
+ use python && distutils-r1_src_install
+}