summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2022-05-23 17:11:02 +0200
committerGuilherme Amadio <amadio@gentoo.org>2022-05-23 17:17:15 +0200
commit0e8f9e7b0f439e7f85c099b8bbd1e3d3ecbb0e92 (patch)
treee52b2853f873c2dd4e04d47b031f8a84517ccf2b
parentdev-util/perf: version bump to 5.18 (diff)
downloadgentoo-0e8f9e7b0f439e7f85c099b8bbd1e3d3ecbb0e92.tar.gz
gentoo-0e8f9e7b0f439e7f85c099b8bbd1e3d3ecbb0e92.tar.bz2
gentoo-0e8f9e7b0f439e7f85c099b8bbd1e3d3ecbb0e92.zip
sci-physics/geant: fix bug 839237
Closes: https://bugs.gentoo.org/839237 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--sci-physics/geant/geant-4.10.7.3.ebuild4
-rw-r--r--sci-physics/geant/geant-4.11.0.0.ebuild4
-rw-r--r--sci-physics/geant/geant-4.11.0.1.ebuild2
3 files changed, 5 insertions, 5 deletions
diff --git a/sci-physics/geant/geant-4.10.7.3.ebuild b/sci-physics/geant/geant-4.10.7.3.ebuild
index b25e1a0f55d8..fe10d40f4664 100644
--- a/sci-physics/geant/geant-4.10.7.3.ebuild
+++ b/sci-physics/geant/geant-4.10.7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -67,7 +67,7 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DGEANT4_BUILD_CXXSTD=$((usev c++11 || usev c++14 || usev c++17) | cut -c4-)
+ -DGEANT4_BUILD_CXXSTD=$( (usev c++11 || usev c++14 || usev c++17) | cut -c4-)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=OFF
-DGEANT4_BUILD_TLS_MODEL=$(usex threads global-dynamic initial-exec)
diff --git a/sci-physics/geant/geant-4.11.0.0.ebuild b/sci-physics/geant/geant-4.11.0.0.ebuild
index 589a2cd089b5..e0a6cc6d6c5d 100644
--- a/sci-physics/geant/geant-4.11.0.0.ebuild
+++ b/sci-physics/geant/geant-4.11.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -80,7 +80,7 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DCMAKE_CXX_STANDARD=$((usev c++17 || usev c++20) | cut -c4-)
+ -DCMAKE_CXX_STANDARD=$( (usev c++17 || usev c++20) | cut -c4-)
-DGEANT4_BUILD_BUILTIN_BACKTRACE=$(usex debug)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=OFF
diff --git a/sci-physics/geant/geant-4.11.0.1.ebuild b/sci-physics/geant/geant-4.11.0.1.ebuild
index 1ea83a6f144f..9112a2515352 100644
--- a/sci-physics/geant/geant-4.11.0.1.ebuild
+++ b/sci-physics/geant/geant-4.11.0.1.ebuild
@@ -78,7 +78,7 @@ S="${WORKDIR}/${MY_P}"
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DATADIR="${EPREFIX}/usr/share/geant4"
- -DCMAKE_CXX_STANDARD=$((usev c++17 || usev c++20) | cut -c4-)
+ -DCMAKE_CXX_STANDARD=$( (usev c++17 || usev c++20) | cut -c4-)
-DGEANT4_BUILD_BUILTIN_BACKTRACE=$(usex debug)
-DGEANT4_BUILD_MULTITHREADED=$(usex threads)
-DGEANT4_BUILD_STORE_TRAJECTORY=OFF