summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:45 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:53 +0100
commit0ec7ebf83f8055f4a9e3003d76a77db44165debb (patch)
tree77f1930e352bd8240858995a56ba70493bb92ce7
parentdev-haskell/microstache: add 1.0.2.3-r1 (diff)
downloadgentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.tar.gz
gentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.tar.bz2
gentoo-0ec7ebf83f8055f4a9e3003d76a77db44165debb.zip
dev-haskell/missingh: add 1.6.0.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/missingh/Manifest1
-rw-r--r--dev-haskell/missingh/metadata.xml8
-rw-r--r--dev-haskell/missingh/missingh-1.6.0.0.ebuild38
3 files changed, 41 insertions, 6 deletions
diff --git a/dev-haskell/missingh/Manifest b/dev-haskell/missingh/Manifest
index c6063886177b..42f3df739849 100644
--- a/dev-haskell/missingh/Manifest
+++ b/dev-haskell/missingh/Manifest
@@ -1 +1,2 @@
DIST MissingH-1.4.3.0.tar.gz 107358 BLAKE2B fa6cf7efd1a60defce6ec0e6bbee229b71f5afe4140cca31dd47c54fbeb8a2a7b0f3e41e4ccba3e010ab85c21fad4d9bb392bd4481a01a945a77de7366b6eae6 SHA512 eb42ad9fd09347d2ec661f8181c6d2c95fb4f9f05634373ac27b377508056afd909b4925f725b9e11441ee9877b66b46038005e469d0b754f8f6cb1cda66d1dc
+DIST missingh-1.6.0.0.tar.gz 109652 BLAKE2B ff7faa78c0d48108da83ead5bfa8a137270b3c1c520dfca683923d05b1c14ba581b49e6e713535ea6a596684d5ef55ed54ae8cbd9a8605ce3fd4b2dccda5dafe SHA512 f49cf93bf172e5ed41a05af4d12d05d6b2dcde61a94b42f2f8be2931458ed622af45051c02a30f71d8ce359548b13d1a7afcd7b458b4a68e78896014a33923a0
diff --git a/dev-haskell/missingh/metadata.xml b/dev-haskell/missingh/metadata.xml
index a15becf07ceb..d7d3cd104993 100644
--- a/dev-haskell/missingh/metadata.xml
+++ b/dev-haskell/missingh/metadata.xml
@@ -5,12 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- MissingH is a library of all sorts of utility functions for
- Haskell programmers. It is written in pure Haskell and thus should
- be extremely portable and easy to use.
- </longdescription>
<upstream>
- <remote-id type="github">jgoerzen/missingh</remote-id>
+ <remote-id type="hackage">MissingH</remote-id>
+ <remote-id type="github">haskell-hvr/missingh</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/missingh/missingh-1.6.0.0.ebuild b/dev-haskell/missingh/missingh-1.6.0.0.ebuild
new file mode 100644
index 000000000000..ccd03c06605a
--- /dev/null
+++ b/dev-haskell/missingh/missingh-1.6.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: +network--ge-3_0_0
+
+CABAL_PN="MissingH"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Large utility library"
+HOMEPAGE="https://hackage.haskell.org/package/MissingH"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+RDEPEND=">=dev-haskell/hslogger-1.3.0.0:=[profile?] <dev-haskell/hslogger-1.4:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?] <dev-haskell/network-3.2:=[profile?]
+ >=dev-haskell/network-bsd-2.8.1:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
+ >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+ >=dev-haskell/old-time-1.1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
+ || ( dev-lang/ghc ( >=dev-haskell/process-1.1.0.1[profile?] <dev-haskell/process-1.7[profile?] ) )
+ >=dev-haskell/regex-compat-0.95.1:=[profile?] <dev-haskell/regex-compat-0.96:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network--ge-3_0_0
+}