summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-17 00:25:38 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-17 00:30:36 +0300
commit0ee55a3ef60a76aa7662f02a8afce9c24786d2bf (patch)
treefe7c7dfee8f10f92196fa8f55ad061e5ee6facd7
parentwww-apps/gitea: drop 1.21.5 (diff)
downloadgentoo-0ee55a3ef60a76aa7662f02a8afce9c24786d2bf.tar.gz
gentoo-0ee55a3ef60a76aa7662f02a8afce9c24786d2bf.tar.bz2
gentoo-0ee55a3ef60a76aa7662f02a8afce9c24786d2bf.zip
dev-python/qscintilla-python: fixup dependencies
Remove 'cups' from 'qtbase', since 'gui,widgets' should be enough here (was also changed in 'x11-libs/qscintilla', but was forgotten here). Also adjust the 'qt5/qt6' USE dependency. Closes: https://bugs.gentoo.org/930118 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.14.1-r2.ebuild112
1 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.14.1-r2.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.14.1-r2.ebuild
new file mode 100644
index 000000000000..23fc7f5155df
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.14.1-r2.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit multibuild python-r1 qmake-utils out-of-source-utils
+
+DESCRIPTION="Python bindings for QScintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/ https://pypi.org/project/QScintilla/"
+
+MY_PN=QScintilla
+MY_P=${MY_PN}_src-${PV/_pre/.dev}
+SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}/Python
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="debug +qt5 qt6"
+
+REQUIRED_USE="|| ( qt5 qt6 ) ${PYTHON_REQUIRED_USE}"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ qt5? (
+ >=dev-python/PyQt5-5.15.5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+ qt6? (
+ dev-python/PyQt6[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtbase:6[gui,widgets]
+ )
+ ~x11-libs/qscintilla-${PV}:=[qt5(+)?,qt6(-)?]
+"
+RDEPEND="${DEPEND}
+ qt5? ( >=dev-python/PyQt5-sip-12.9:=[${PYTHON_USEDEP}] )
+ qt6? ( >=dev-python/PyQt6-sip-13.5:=[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ >=dev-python/PyQt-builder-1.10[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.2[${PYTHON_USEDEP}]
+ qt5? ( dev-qt/qtcore:5 )
+ qt6? ( dev-qt/qtbase:6 )
+"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ case ${MULTIBUILD_VARIANT} in
+ qt5)
+ configuration() {
+ local myconf=(
+ sip-build
+ --verbose
+ --build-dir="${BUILD_DIR}"
+ --scripts-dir="$(python_get_scriptdir)"
+ --qmake="$(qt5_get_bindir)"/qmake
+ --no-make
+ $(usev debug '--debug --qml-debug --tracing')
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ run_in_build_dir qmake5 -recursive ${MY_PN}.pro
+ }
+ mv pyproject{-${MULTIBUILD_VARIANT},}.toml || die
+ python_foreach_impl configuration
+ ;;
+ qt6)
+ configuration() {
+ local myconf=(
+ sip-build
+ --verbose
+ --build-dir="${BUILD_DIR}"
+ --scripts-dir="$(python_get_scriptdir)"
+ --qmake="$(qt6_get_bindir)"/qmake
+ --no-make
+ $(usev debug '--debug --qml-debug --tracing')
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ run_in_build_dir qmake6 -recursive ${MY_PN}.pro
+ }
+ mv pyproject{-${MULTIBUILD_VARIANT},}.toml || die
+ python_foreach_impl configuration
+ ;;
+ esac
+ }
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ multibuild_foreach_variant python_foreach_impl run_in_build_dir installation
+}