summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-20 21:08:38 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-20 21:23:33 +0200
commit0ef4adac80aafdc12e57a71f7230c0e91d68fe00 (patch)
tree52edcce8c24bc1c8f79c1050e2126f814af14e83
parentdev-java/openjdk: fix bootstrap logic err in 17 (diff)
downloadgentoo-0ef4adac.tar.gz
gentoo-0ef4adac.tar.bz2
gentoo-0ef4adac.zip
dev-python/sentry-sdk: add 1.5.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.5.3.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index cafb3cfd39f8..62a755b9e6a6 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,2 +1,3 @@
DIST sentry-sdk-1.5.1.tar.gz 234143 BLAKE2B 431216c66b195ef7f26fe74d5f2c6e4697d93209ccf650bc0f043f4e7c6bf38a3fa98f39f75d94bc66247a91d0b3e3b85f4fa1912c0f71827a912e65fb976468 SHA512 09e178e5abe2e47d29aee778c8fb48ea5e09efa278dd970e3c856dd04704ef63f3adba0edb68a73c09baa2291bae41cd6fd081dd9f0a2792c1edda480fe1f4b4
DIST sentry-sdk-1.5.2.tar.gz 238538 BLAKE2B b5ec8da91e6eaf76e5501a3e97e6a06f67b6afb887fcc161ca4c5c6750e294cdb2c72eb7f8ff62b06cb27410f580d3a7ce3aa5981282719a4e4eba3892781394 SHA512 5bac6ce88a2a2f9b6269d6c2483568cbb627e7fb338044272785d1fcd574c7772e47c7304bdc3082058883d53d7ca458f65b3ceeb6d7a7fd70b752b335105193
+DIST sentry-sdk-1.5.3.tar.gz 239237 BLAKE2B ce519926fd1873d1c94b76816c8e1d4831d0893ca030e7703d0976dd54930847bd4b1ab7f55ec45c0826bf4ae559a4d56e980f280973f660ff02061b02bd47a6 SHA512 47614f77f31aaaf4891da0dcf64c42e8f2bf42a6d776cba92beb5dab4de6ee28e0f65bd47293c14e9b847455293de021420592bb80af4a4e2e52a3bb89e5d869
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.5.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.5.3.ebuild
new file mode 100644
index 000000000000..f7fe237c12d9
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.5.3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ ' python3_{8..9})
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # broken by rq-1.10.1 (optional dep)
+ tests/integrations/rq/test_rq.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # hangs
+ 'tests/test_transport.py::test_transport_works'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ tests/integrations/sqlalchemy/test_sqlalchemy.py::test_too_large_event_truncated
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest
+}