summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-02 15:25:08 -0500
committerSam James <sam@gentoo.org>2024-02-02 20:29:21 +0000
commit0f1419bfe24ee1019b3bd080d06ed2745b794421 (patch)
tree233feff7a5205dd602f58eb9b614318957dba8f7
parentapp-text/ansifilter: fix prefix install (diff)
downloadgentoo-0f1419bf.tar.gz
gentoo-0f1419bf.tar.bz2
gentoo-0f1419bf.zip
net-mail/fetchmail: drop old
Drops remaining dev-python/future revdep from the tree. Bug: https://bugs.gentoo.org/888295 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.27.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index f12f97eb18d1..2d76b253b809 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1 @@
-DIST fetchmail-6.4.27.tar.xz 1326668 BLAKE2B fb349f8e4b17929d8ab5ec144e2d6e4227b56143112eb3745830c339f8dfdaa80fb47060ad3671258563198ed1283a903fcd5a82564b7320a829ceb4c5826642 SHA512 75650c2a8bcfa6f4364dacd6964f00848a23e1bc96eed10f7fcfd9c8c6f6b6fe60eee2730c57c8a5263c11f01b3031cbef7d6b2bffa730de63e7ec262448af2f
DIST fetchmail-6.4.37.tar.xz 1202860 BLAKE2B 4dc7d116e9dc32c2ff070f669306d9f2c0f93d5638b748d7362d6c9ab8684ae7ed8e26278ecf63bf23e2fff27916f83f7287aff891bd90bad82793bb84775c40 SHA512 99a620380d9bd0713d76495f587adbcc95fc16e5fcb048dc528f3039ebd8fcfbb1e2f44e10fc25f70e50940ce89922ff39f1f3d724d1f47a8d4918a37c07d8d0
diff --git a/net-mail/fetchmail/fetchmail-6.4.27.ebuild b/net-mail/fetchmail/fetchmail-6.4.27.ebuild
deleted file mode 100644
index 5e9b59cdefa6..000000000000
--- a/net-mail/fetchmail/fetchmail-6.4.27.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-PYTHON_REQ_USE="tk"
-
-inherit autotools python-single-r1 systemd tmpfiles toolchain-funcs
-
-DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
-HOMEPAGE="https://www.fetchmail.info/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2 public-domain"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
-IUSE="ssl nls kerberos tk socks"
-REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="acct-user/fetchmail
- ssl? (
- >=dev-libs/openssl-1.1.1:=
- )
- kerberos? (
- virtual/krb5
- >=dev-libs/openssl-1.0.2:=
- )
- nls? ( virtual/libintl )
- !elibc_glibc? ( sys-fs/e2fsprogs )
- socks? ( net-proxy/dante )
- tk? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/future[${PYTHON_USEDEP}]
- ')
- )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- app-alternatives/lex
- nls? ( sys-devel/gettext )"
-
-DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
-HTML_DOCS="*.html"
-PATCHES=(
- "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
-)
-S=${WORKDIR}/${P/_/.}
-
-pkg_setup() {
- use tk && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- # don't compile during src_install
- use tk && : > "${S}"/py-compile
- eautoreconf
-}
-
-src_configure() {
- use tk || export PYTHON=:
-
- econf \
- --enable-RPA \
- --enable-NTLM \
- --enable-SDPS \
- $(use_enable nls) \
- $(use_with ssl ssl "${EPREFIX}/usr") \
- $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
- $(use_with kerberos gssapi) \
- $(use_with kerberos kerberos5) \
- --without-hesiod \
- $(use_with socks)
-}
-
-src_compile() {
- emake AR="$(tc-getAR)"
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/fetchmail.initd fetchmail
- newconfd "${FILESDIR}"/fetchmail.confd fetchmail
-
- systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
- dotmpfiles "${FILESDIR}"/${PN}.conf
-
- docinto contrib
- local f
- for f in contrib/* ; do
- [ -f "${f}" ] && dodoc "${f}"
- done
-
- use tk && python_optimize
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "Please see /etc/conf.d/fetchmail if you want to adjust"
- elog "the polling delay used by the fetchmail init script."
- fi
-}