summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-08-14 08:04:20 +0200
committerHans de Graaff <graaff@gentoo.org>2022-08-14 08:24:51 +0200
commit0f1631f43e7abe6899492050b503a28a54079685 (patch)
tree08c22ef7138339f63ed1e109de7a2b12efa83f60
parentdev-ruby/childlabor: enable ruby30, ruby31 (diff)
downloadgentoo-0f1631f43e7abe6899492050b503a28a54079685.tar.gz
gentoo-0f1631f43e7abe6899492050b503a28a54079685.tar.bz2
gentoo-0f1631f43e7abe6899492050b503a28a54079685.zip
dev-ruby/rack-test: drop 1.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rack-test/rack-test-1.1.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/rack-test/rack-test-1.1.0.ebuild b/dev-ruby/rack-test/rack-test-1.1.0.ebuild
deleted file mode 100644
index 0f5bff84d58f..000000000000
--- a/dev-ruby/rack-test/rack-test-1.1.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Rack::Test is a small, simple testing API for Rack apps"
-HOMEPAGE="https://github.com/rack-test/rack-test"
-SRC_URI="https://github.com/rack-test/rack-test/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="1.0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/rack-1.0:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "
- test? ( dev-ruby/sinatra:2 )"
-
-all_ruby_prepare() {
- rm Gemfile* || die
- sed -e '/bundler/d' \
- -e '/[Cc]ode[Cc]limate/d' \
- -e '/simplecov/,/^end/ s:^:#:' \
- -i spec/spec_helper.rb || die
- sed -i -e 's/git ls-files --/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid test broken with rack 2.2
- sed -i -e '/closes response.s body/askip "rack 2.2 compatibility"' spec/rack/test_spec.rb || die
-}