summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-04 07:22:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-04 07:31:21 +0100
commit0f2a5d58ca175c0e091dfc325aea471de84f4875 (patch)
treedc8a0a171bc2601ac6336926854ebed23c419da6
parentdev-python/time-machine: Bump to 2.14.0 (diff)
downloadgentoo-0f2a5d58ca175c0e091dfc325aea471de84f4875.tar.gz
gentoo-0f2a5d58ca175c0e091dfc325aea471de84f4875.tar.bz2
gentoo-0f2a5d58ca175c0e091dfc325aea471de84f4875.zip
dev-python/trove-classifiers: Bump to 2024.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 66f57ae5e822..7faf740d83dc 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,3 +1,4 @@
DIST trove-classifiers-2024.1.31.tar.gz 15958 BLAKE2B c08cd4c7a13cd1473171bb8f5ed478f649bc1083d9881e260d43a2a3fb2679cf0f7ac926af3136d593cab63266826545be35301bf4d18a0b9b2d5919a31d0b74 SHA512 b77f2a84a89a4f5ce3ee94921d7d293bd70869af53632ffc0e08a4e0e3876c5ca4e86aefef0622be3d1a2f4eb5f153f294bbec251431373d1e98418a76cf93fb
DIST trove-classifiers-2024.2.22.tar.gz 15951 BLAKE2B 97afd582592d094a226f3deb8076b0c4bbd9b1321d57eeef4a4e45088825d23ff07102d34a5192b62f3d509de744ae923876d2b3a98513fe1305e71edc2ddab4 SHA512 efbcf87d5c197b26e7972fff2b024dc7044941cf29c61b9a652227f28590f9a4063ac3738130c94e913232828ae386967265e3d405c11a160aff9c0af888a16a
DIST trove-classifiers-2024.2.23.tar.gz 15976 BLAKE2B 48327abd7c5b4cc20725247082420c70981ec47d2e82e1bda70499fffc80787d456e1ea46c03df7e08848adb922a8f38c39321e2f886639d5c3967c1fcc26e88 SHA512 8099d9c66099c43a8d8eb29b47cfd33d3ca893f434fbcd14c3d5ce5561a385ca382ba772933fc8303f900af2067b86ecce34adb8f5962211aa54c62e968e3ce1
+DIST trove-classifiers-2024.3.3.tar.gz 15982 BLAKE2B 7cfa726b25bfa1714d022e8bbdbb2b02a0c4d8395d3bd1d0abeb85706889b10bf990f18329cd588de8523a961710cf23219bdc5c8a1480f7ebbaeea4dca786ff SHA512 be034c60cbc9d3a684cea33d30e8387994e90bbb9e20e57533ed18cb3ccbd5f51a251d97dca5db09b006228bc1a919cc4543ddc83dd341d94e4b800a72cb3623
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}