summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-01-16 19:39:28 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-01-22 06:29:25 -0500
commit0f2e12f7aa02ef63b84cfc748d851a9044e55b76 (patch)
tree4ddbb760f63aa03c57c4b1d43ee043db3a30c905
parentdev-gap/utils: update LICENSE (diff)
downloadgentoo-0f2e12f7aa02ef63b84cfc748d851a9044e55b76.tar.gz
gentoo-0f2e12f7aa02ef63b84cfc748d851a9044e55b76.tar.bz2
gentoo-0f2e12f7aa02ef63b84cfc748d851a9044e55b76.zip
sci-mathematics/gap: use a bash array for econf args
Suggested-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/gap/gap-4.12.2-r3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-mathematics/gap/gap-4.12.2-r3.ebuild b/sci-mathematics/gap/gap-4.12.2-r3.ebuild
index 2ccaded522a5..d44da14dfd8a 100644
--- a/sci-mathematics/gap/gap-4.12.2-r3.ebuild
+++ b/sci-mathematics/gap/gap-4.12.2-r3.ebuild
@@ -97,15 +97,17 @@ src_prepare() {
src_configure() {
# We unset $ABI because GAP uses it internally for something else.
# --without-gmp and --without-zlib both trigger an AC_MSG_ERROR
- econf \
- ABI="" \
- --with-gmp \
- --with-zlib \
- $(use_enable cpu_flags_x86_popcnt popcnt) \
- $(use_enable memcheck memory-checking) \
- $(use_enable valgrind) \
- $(use_with readline) \
+ local myeconfargs=(
+ ABI=""
+ --with-gmp
+ --with-zlib
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+ $(use_enable memcheck memory-checking)
+ $(use_enable valgrind)
+ $(use_with readline)
$(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
}
src_compile() {