summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-05 14:43:25 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-05 15:12:35 -0400
commit0f373ad4d1e9dd22626f956666bcf18bcfa4fb4d (patch)
tree7436e616f6c2ee089874e0d29f9904ca307f0c42
parentdev-php/PEAR-Net_IPv4: Revbump for EAPI and eclass changes (diff)
downloadgentoo-0f373ad4d1e9dd22626f956666bcf18bcfa4fb4d.tar.gz
gentoo-0f373ad4d1e9dd22626f956666bcf18bcfa4fb4d.tar.bz2
gentoo-0f373ad4d1e9dd22626f956666bcf18bcfa4fb4d.zip
dev-php/PEAR-HTML_TreeMenu: Revbump for EAPI and eclass changes
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild b/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..e16842bc503c
--- /dev/null
+++ b/dev-php/PEAR-HTML_TreeMenu/PEAR-HTML_TreeMenu-1.2.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides an API to create a HTML tree"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_install() {
+ php-pear-r2_src_install
+ docinto html
+ dodoc -r TreeMenu.js images imagesAlt imagesAlt2 imagesAlt3 docs/example.php
+}
+
+pkg_postinst() {
+ elog "Please copy the TreeMenu.js and the contents of one of the images"
+ elog "directory from ${EROOT}usr/share/doc/${PF}/html to the same location"
+ elog "in your website for this script to work properly"
+}