summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-11-10 11:24:39 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-11-10 11:24:54 -0600
commit0f41092cfce78ad19a3223690e7e600b266a2192 (patch)
tree53b40631c5c26658c955bc6aedb3e61adda8a6b2
parentdev-util/glslang: Bump slot (diff)
downloadgentoo-0f41092cfce78ad19a3223690e7e600b266a2192.tar.gz
gentoo-0f41092cfce78ad19a3223690e7e600b266a2192.tar.bz2
gentoo-0f41092cfce78ad19a3223690e7e600b266a2192.zip
mail-client/aerc: add 0.16.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--mail-client/aerc/Manifest2
-rw-r--r--mail-client/aerc/aerc-0.16.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/mail-client/aerc/Manifest b/mail-client/aerc/Manifest
index 80a39de3bbb0..57df81dbcadb 100644
--- a/mail-client/aerc/Manifest
+++ b/mail-client/aerc/Manifest
@@ -2,3 +2,5 @@ DIST aerc-0.14.0-deps.tar.xz 312747732 BLAKE2B bfba50f224132b3f21cf052788c41d15d
DIST aerc-0.14.0.tar.gz 332575 BLAKE2B 6d133c9c4cd21da610d271c60dcbc1654a35c7a7592791572283648101de9a60cb0da7b2642fde114acdfa2108e3405f4d2fec884e0f5fa5b7fc096704e5f9ff SHA512 d12502a809c5163bc81bfa3bfbd471a03f4e8e56084e00e7bb52619a8ac6f34df78342c0e8e82d6cdfd4fe1bc0c375dd65366a442875621b20bbd040a9025831
DIST aerc-0.15.2-deps.tar.xz 46530556 BLAKE2B 7ea7fa49dcb38e9fe54e224092cb3aa8964533d52fb408450188ac8094fb9a14bb093fc731f4dc2bde56fac5d71df36e274bab6563331890510a3b2c0068f94b SHA512 47dceb5b9af3b79c8f67ed25e85bdb5b6d0d10b07a132662d645bba78ba2620f4e14e7901d5c816b6b79695ecdeba8458ba1c0890ef781a6c32325da7c7fa675
DIST aerc-0.15.2.tar.gz 331263 BLAKE2B 9426fb0b857374913e1da0712e2acab3f155c78b02b5855aac51d460519c31cb768f669da089122402c5e2e555b356334cf755b8ba2dbf9c9c41f3e54c4ef3ff SHA512 8744c6c5ea45fc8ad2ab46367e92d3859fab962843db4329c7655b0afe7b72dbea21dae588d44eab314a31da89d15e5b6543224699556aed31e0b3b9c7b0ddbc
+DIST aerc-0.16.0-deps.tar.xz 47250564 BLAKE2B 27c3d7b8276ef4b56f14b187ed707ce1e7ad8d2c265a94775da82f04e585b3b6661e6760e38b3d81c8ce0fe15de49e37cd9eec9e97528ee0a7ed3dc94d278adb SHA512 fb8b43dbc7586e0ff0e58117ee04cffdd7f03988530a8d4f05f2adefc7c4f22db9eea1a693f26df8f1ca71490f7e39f6900ceaf8ac735f48bf51937e0afd8ac4
+DIST aerc-0.16.0.tar.gz 387833 BLAKE2B b001ea88f07aafba115ffa08f176f4c96f219c86fcaee1aee2eca7d9d7469d861b74376dffc4e5bc2c3110020cc350df64758386e10548b6c1ef95362fcc1181 SHA512 8196424915f8f6dc80bad0f936e34b7f51298665af3579ae8c06699a4f1caf962258185a432909911920ec1eb089c9f178c9086c54c0e799a44e1e0dac907fd8
diff --git a/mail-client/aerc/aerc-0.16.0.ebuild b/mail-client/aerc/aerc-0.16.0.ebuild
new file mode 100644
index 000000000000..c54807fff2de
--- /dev/null
+++ b/mail-client/aerc/aerc-0.16.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module xdg
+
+DESCRIPTION="Email client for your terminal"
+HOMEPAGE="https://aerc-mail.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~rjarry/aerc"
+else
+ SRC_URI="https://git.sr.ht/~rjarry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+IUSE="notmuch"
+
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=app-text/scdoc-1.9.7
+ >=dev-lang/go-1.16
+"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ unset LDFLAGS
+ emake GOFLAGS="$(usex notmuch "-tags=notmuch" "")" \
+ PREFIX="${EPREFIX}/usr" VERSION=${PV} all
+}
+
+src_install() {
+ emake GOFLAGS="$(usex notmuch "-tags=notmuch" "")" \
+ DESTDIR="${ED}" PREFIX="${EPREFIX}/usr" VERSION="${PV}" install
+ einstalldocs
+dodoc CHANGELOG.md
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you want to allow your users to activate html email"
+ elog "processing via w3m as shown in the tutorial, make sure you"
+ elog "emerge net-proxy/dante and www-client/w3m"
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test $v -lt 0.3.0-r1; then
+ elog "The dependencies on net-proxy/dante and www-client/w3m"
+ elog "have been removed since they are optional."
+ elog "Please emerge them before the next --depclean if you"
+ elog "need to use them."
+ fi
+ done
+ xdg_pkg_postinst
+}