summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-30 13:17:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-30 13:17:19 +0200
commit0f5ad79359e4f8e19030f0f62985be242c81fe67 (patch)
tree28bd715d296280972955f738cf469d70db7cc7f7
parentdev-python/sphinx-tabs: Remove old (diff)
downloadgentoo-0f5ad793.tar.gz
gentoo-0f5ad793.tar.bz2
gentoo-0f5ad793.zip
dev-python/hypothesis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.46.11.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 56b07d9475f3..c232913e5bc4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,4 +4,3 @@ DIST hypothesis-6.52.2.gh.tar.gz 9321530 BLAKE2B d54b97bf15895b503d14629c61cd99d
DIST hypothesis-6.52.3.gh.tar.gz 9321591 BLAKE2B 50415d463d2513b023b8a6ac87a2bb6dae433b823fd209ec1137a26184bb5550fb9606e006cffecbff09c523fb244b9f8c119e1c9dc765b925f8aa6b0dc43bed SHA512 f8aae5976cc2bd47e157310434d2717caea5e639daf1d794fa6c45332fe44fc5873904451f1fb0b53d56e64147428c4c87e130b4776fd3b14e2c2b961660231d
DIST hypothesis-6.52.4.gh.tar.gz 9323011 BLAKE2B fece23da48d4849252a0fa48ae741506f49aa1f2b63f81afe3b71d18e0325a4e337bebde1a1707390d38bdf57e2ce1145985231f68557b36c58886d82774a7d9 SHA512 c51f29d52757d08652f83deda48825ca38c86e0bc67743c2cff9c85f52d726671f07d0249dfdc761b2ba8250d40beacdf5e037e8629f24df5baeddd297f38030
DIST hypothesis-6.53.0.gh.tar.gz 9323355 BLAKE2B 589cd4803351e72cc1896453e5e548bb6fb5f998032bce91708e02f3c8ff5d288ec76d65eeffde5fa31b6b86fbb3ad81dfe3eebaaac841f197de3a07acfa12bd SHA512 ab4de3764ca3ce8e5e50966ea94fcadd85e7c9f170dbbd17383b5516528e091ebfe3b06846513ee77a1f7a2e827236d323c12cc120cac421ec7aa9f3a2ca5e4a
-DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
diff --git a/dev-python/hypothesis/hypothesis-6.46.11.ebuild b/dev-python/hypothesis/hypothesis-6.46.11.ebuild
deleted file mode 100644
index 0dba02dcf600..000000000000
--- a/dev-python/hypothesis/hypothesis-6.46.11.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-CLI_COMPAT=( python3_{8..10} )
-PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 multiprocessing optfeature
-
-TAG=hypothesis-python-${PV}
-MY_P=hypothesis-${TAG}
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="
- https://github.com/HypothesisWorks/hypothesis/
- https://pypi.org/project/hypothesis/
-"
-SRC_URI="
- https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_P}/hypothesis-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="cli"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
- cli? (
- $(python_gen_cond_dep '
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- ' "${CLI_COMPAT[@]}")
- )
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # subtests are broken by warnings from random plugins
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
-
- epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
-}
-
-python_install() {
- distutils-r1_python_install
- if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
- rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
- fi
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}