summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:15:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:15:48 +0300
commit0f675dc86c187b3178bc70f86e9ab621399413b6 (patch)
tree6dd892ee1dd37856c4b8555f4ae3148931fd2917
parentdev-python/botocore: add 1.27.23 (diff)
downloadgentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.tar.gz
gentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.tar.bz2
gentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.zip
dev-python/jc: add 1.20.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.20.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index bd435d1ebfdf..6c03a0cbd07b 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1 +1,2 @@
DIST jc-1.20.1.gh.tar.gz 10342360 BLAKE2B fe7eb94e53a78e6d2c1f13403ac529e4e0c0251a9e5f8270e88a94c7d086b7b1eca5cf8bd51ab6b514923ac2de95b7365b8ee29eeae5a1bb861e911f70be81d8 SHA512 d066b30089fce8bb7aff6db0b278f258a91bbef73bc49abb0b086b1cce5253a0ba07efa9e3680ee6ee333ea4a2b6afcfe4028eee58d0ec16411f7c257a54a9b5
+DIST jc-1.20.2.gh.tar.gz 10468681 BLAKE2B 185937c277989536bfed42ee27717a2dee1c4672565b7c2dbe6c3146ca6520e7952aef98d67b94c15b1cc3a2bac3eeafe7353644d8379cedc5c657c2ff9255d1 SHA512 80e851eaef0a3159d7ec8c295d8118692b45799359b131396319489ef9aa3d1567cfea4f1382ec857a82707857977b70d11166426cc1a92fb81186ee68bd017e
diff --git a/dev-python/jc/jc-1.20.2.ebuild b/dev-python/jc/jc-1.20.2.ebuild
new file mode 100644
index 000000000000..7b7bbfc30991
--- /dev/null
+++ b/dev-python/jc/jc-1.20.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest