summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-11-23 09:13:28 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-11-23 09:13:36 +0100
commit0fcdda47d983bcca6785537021c8e07aa4959434 (patch)
tree911c18107385be7277fa727782bf3c635cea76e5
parentdev-python/redis-py: Replace elog with einfo (diff)
downloadgentoo-0fcdda47d983bcca6785537021c8e07aa4959434.tar.gz
gentoo-0fcdda47d983bcca6785537021c8e07aa4959434.tar.bz2
gentoo-0fcdda47d983bcca6785537021c8e07aa4959434.zip
media-sound/fluidsynth: bump to 2.2.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.4.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index bf9e482d2f3c..33eb4007d74f 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1 +1,2 @@
DIST fluidsynth-2.2.3.tar.gz 1745344 BLAKE2B 0d08c67532392d32501a71f1e6fac6d55a0a0a607dae914106e1674df0a96869041530f75669193305a091ec40177e2925345df24d75a369c87e738ec1f4eb2e SHA512 67f8da02714350cc0439fbdce763d00cb08d01301a6aaa3e2655e67935048b43e18968c9a52aa64c702b5e30ae2b2b4946f69e8be4af5889fa414c654d4eb13e
+DIST fluidsynth-2.2.4.tar.gz 1746638 BLAKE2B 28a2a8048ad3f652afd424358b1b268d42672eb8fba0bdb30c72c06041617844fb5b90bc922e905d80ca2818eac03e9e5ce7f9a57b4cf68a43f60ed4bfddcd49 SHA512 46c3f0759cc011f34e5ba80684df4e8b593315d564da2341aaea14a5f0ba9cf732933f6ebc8712506f194b044a8e2b198b9e50879ff4221e6a9ab8051e79b48f
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.4.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.4.ebuild
new file mode 100644
index 000000000000..a285914d267a
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-2.2.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib systemd
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="https://www.fluidsynth.org"
+SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss portaudio pulseaudio +readline sdl +sndfile systemd threads"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ alsa? (
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
+ )
+ dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? (
+ media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
+ media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
+ )
+ portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
+ pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -Denable-alsa=$(usex alsa)
+ -Denable-aufile=ON
+ -Denable-dbus=$(usex dbus)
+ -Denable-debug=$(usex debug)
+ -Denable-dsound=OFF # Windows
+ -Denable-floats=OFF # loat instead of double for DSP samples
+ -Denable-fpe-check=$(usex debug)
+ -Denable-ipv6=$(usex ipv6)
+ -Denable-jack=$(usex jack)
+ -Denable-ladspa=$(usex ladspa)
+ -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
+ -Denable-midishare=OFF # http://midishare.sourceforge.net/
+ -Denable-network=$(usex network)
+ -Denable-opensles=OFF
+ -Denable-oboe=OFF # requires OpenSLES and/or AAudio
+ -Denable-oss=$(usex oss)
+ -Denable-libsndfile=$(usex sndfile)
+ -Denable-pkgconfig=ON
+ -Denable-portaudio=$(usex portaudio)
+ -Denable-profiling=$(usex debug)
+ -Denable-pulseaudio=$(usex pulseaudio)
+ -Denable-readline=$(usex readline)
+ -Denable-sdl2=$(usex sdl)
+ -Denable-systemd=$(usex systemd)
+ -Denable-threads=$(usex threads)
+ -Denable-trap-on-fpe=$(usex debug)
+ -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
+ -Denable-waveout=OFF # Windows
+ -Denable-winmidi=OFF # Windows
+ )
+
+ if use alsa; then
+ mycmakeargs+=( -Denable-lash=$(usex lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ if use systemd; then
+ mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+install_systemd_files() {
+ if multilib_is_native_abi; then
+ systemd_dounit "${BUILD_DIR}/fluidsynth.service"
+ insinto /etc
+ doins "${BUILD_DIR}/fluidsynth.conf"
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+
+ if use systemd; then
+ multilib_foreach_abi install_systemd_files
+
+ elog "When using fluidsynth as a systemd service, make sure"
+ elog "to configure your fluidsynth settings globally in "
+ elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
+ fi
+}