summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:27:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 15:37:25 +0100
commit0fce98f8426d4103340b14f22001be312a0a1b16 (patch)
tree76f860616669a3159cf9119403d92c7992a44de0
parent*/*: Switch proaudio proj packages to cmake.eclass (diff)
downloadgentoo-0fce98f8.tar.gz
gentoo-0fce98f8.tar.bz2
gentoo-0fce98f8.zip
*/*: Switch qt proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-editors/juffed/juffed-0.10_p20160323-r1.ebuild6
-rw-r--r--app-emulation/q4wine/q4wine-1.3.11.ebuild4
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild8
-rw-r--r--media-gfx/nomacs/nomacs-3.12.ebuild4
-rw-r--r--x11-libs/qtermwidget/qtermwidget-0.14.1.ebuild2
-rw-r--r--x11-libs/qtermwidget/qtermwidget-9999.ebuild2
-rw-r--r--x11-misc/qlipper/qlipper-5.1.2.ebuild2
-rw-r--r--x11-misc/qps/qps-1.10.20.ebuild2
-rw-r--r--x11-misc/qtfm/qtfm-99999.ebuild4
-rw-r--r--x11-misc/screengrab/screengrab-1.101.ebuild2
-rw-r--r--x11-terms/qterminal/qterminal-0.14.1.ebuild2
-rw-r--r--x11-terms/qterminal/qterminal-9999.ebuild2
12 files changed, 20 insertions, 20 deletions
diff --git a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
index ef84d7ef4612..955c950bbf9e 100644
--- a/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
+++ b/app-editors/juffed/juffed-0.10_p20160323-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
COMMIT=5ba17f90ec173e773470bc80ea26bca9a3f093fd
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
HOMEPAGE="http://juffed.com/en/"
@@ -41,7 +41,7 @@ src_prepare() {
# Upstream version outdated/dysfunctional and CRLF terminated
cp "${FILESDIR}"/FindQtSingleApplication.cmake cmake/ || die
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i -e '/set(CMAKE_CXX_FLAGS/d' CMakeLists.txt || die
}
@@ -54,5 +54,5 @@ src_configure() {
-DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
-DLIB_SUFFIX=${libdir/lib/}
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/app-emulation/q4wine/q4wine-1.3.11.ebuild b/app-emulation/q4wine/q4wine-1.3.11.ebuild
index d7e68124ce8b..4604dd003e7c 100644
--- a/app-emulation/q4wine/q4wine-1.3.11.ebuild
+++ b/app-emulation/q4wine/q4wine-1.3.11.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit xdg cmake-utils
+inherit xdg cmake
# Upstream names the package PV-rX. We change that to
# PV_pX so we can use portage revisions.
@@ -54,5 +54,5 @@ src_configure() {
-DUSE_GZIP=OFF
-DWITH_DBUS=$(usex dbus ON OFF)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild
index 196ec44e9343..fc9fd9ccaf81 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20190629.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 )
USE_RUBY="ruby24 ruby25 ruby26"
MY_P="${PN}-${PV/_pre20190629/-alpha3}" # present as upgrade over previous snapshot
-inherit check-reqs cmake-utils flag-o-matic python-any-r1 qmake-utils ruby-single toolchain-funcs
+inherit check-reqs cmake flag-o-matic python-any-r1 qmake-utils ruby-single toolchain-funcs
DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
HOMEPAGE="https://www.qt.io/"
@@ -116,7 +116,7 @@ src_configure() {
-DENABLE_PRINT_SUPPORT=$(usex printsupport)
-DENABLE_DEVICE_ORIENTATION=$(usex orientation)
-DENABLE_WEBKIT2=$(usex qml)
- $(cmake-utils_use_find_package webp WebP)
+ $(cmake_use_find_package webp WebP)
-DENABLE_X11_TARGET=$(usex X)
)
@@ -128,11 +128,11 @@ src_configure() {
mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby24) )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# bug 572056
if [[ ! -f ${ED}$(qt5_get_libdir)/libQt5WebKit.so ]]; then
diff --git a/media-gfx/nomacs/nomacs-3.12.ebuild b/media-gfx/nomacs/nomacs-3.12.ebuild
index 17e8151bfcf1..a527bc46b3e8 100644
--- a/media-gfx/nomacs/nomacs-3.12.ebuild
+++ b/media-gfx/nomacs/nomacs-3.12.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Qt-based image viewer"
HOMEPAGE="https://nomacs.org/"
@@ -57,7 +57,7 @@ src_configure() {
-DENABLE_TIFF=$(usex tiff)
-DENABLE_QUAZIP=$(usex zip)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/x11-libs/qtermwidget/qtermwidget-0.14.1.ebuild b/x11-libs/qtermwidget/qtermwidget-0.14.1.ebuild
index a4f168095b5b..b7ed36058ef8 100644
--- a/x11-libs/qtermwidget/qtermwidget-0.14.1.ebuild
+++ b/x11-libs/qtermwidget/qtermwidget-0.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Qt terminal emulator widget"
HOMEPAGE="https://lxqt.org/"
diff --git a/x11-libs/qtermwidget/qtermwidget-9999.ebuild b/x11-libs/qtermwidget/qtermwidget-9999.ebuild
index 9c367cc15cbc..e9a17c8f55cd 100644
--- a/x11-libs/qtermwidget/qtermwidget-9999.ebuild
+++ b/x11-libs/qtermwidget/qtermwidget-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Qt terminal emulator widget"
HOMEPAGE="https://lxqt.org/"
diff --git a/x11-misc/qlipper/qlipper-5.1.2.ebuild b/x11-misc/qlipper/qlipper-5.1.2.ebuild
index 412e6dbec0e2..d4b0e226ba39 100644
--- a/x11-misc/qlipper/qlipper-5.1.2.ebuild
+++ b/x11-misc/qlipper/qlipper-5.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Lightweight and cross-platform clipboard history applet"
HOMEPAGE="https://github.com/pvanek/qlipper"
diff --git a/x11-misc/qps/qps-1.10.20.ebuild b/x11-misc/qps/qps-1.10.20.ebuild
index 707dc0fadb37..b585aaca7eb8 100644
--- a/x11-misc/qps/qps-1.10.20.ebuild
+++ b/x11-misc/qps/qps-1.10.20.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Visual process manager - Qt version of ps/top"
HOMEPAGE="https://lxqt.org/"
diff --git a/x11-misc/qtfm/qtfm-99999.ebuild b/x11-misc/qtfm/qtfm-99999.ebuild
index 61cdeb65e860..5d0ee8acd421 100644
--- a/x11-misc/qtfm/qtfm-99999.ebuild
+++ b/x11-misc/qtfm/qtfm-99999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 xdg-utils cmake-utils
+inherit git-r3 xdg-utils cmake
DESCRIPTION="A small, lightweight file manager for desktops based on pure Qt"
HOMEPAGE="https://qtfm.eu/"
@@ -39,7 +39,7 @@ src_configure() {
-DENABLE_FFMPEG="$(usex ffmpeg)"
-DENABLE_MAGICK="$(usex imagemagick)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/x11-misc/screengrab/screengrab-1.101.ebuild b/x11-misc/screengrab/screengrab-1.101.ebuild
index 250095281d0a..a8de9640bb18 100644
--- a/x11-misc/screengrab/screengrab-1.101.ebuild
+++ b/x11-misc/screengrab/screengrab-1.101.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Qt application for getting screenshots"
HOMEPAGE="https://lxqt.org/"
diff --git a/x11-terms/qterminal/qterminal-0.14.1.ebuild b/x11-terms/qterminal/qterminal-0.14.1.ebuild
index 528f35e53d05..aef92c45a4ab 100644
--- a/x11-terms/qterminal/qterminal-0.14.1.ebuild
+++ b/x11-terms/qterminal/qterminal-0.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Qt-based multitab terminal emulator"
HOMEPAGE="https://lxqt.org/"
diff --git a/x11-terms/qterminal/qterminal-9999.ebuild b/x11-terms/qterminal/qterminal-9999.ebuild
index f7797f360159..d95e1018d60a 100644
--- a/x11-terms/qterminal/qterminal-9999.ebuild
+++ b/x11-terms/qterminal/qterminal-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils
+inherit cmake xdg-utils
DESCRIPTION="Qt-based multitab terminal emulator"
HOMEPAGE="https://lxqt.org/"