summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-05-10 22:06:59 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-05-10 22:09:39 +0300
commit0fd0ad6a87e5030e8a61d465a348525bc2ee7ccd (patch)
tree60ad33ee45027623624001281524b75cf0a2a343
parentnet-firewall/nftables: Bump to version 0.8.5 (diff)
downloadgentoo-0fd0ad6a.tar.gz
gentoo-0fd0ad6a.tar.bz2
gentoo-0fd0ad6a.zip
dev-libs/OpenSRF: switch to libmemcached; Minor touchups
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild b/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild
index 66eff92d51a2..7080fd53a102 100644
--- a/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild
+++ b/dev-libs/OpenSRF/OpenSRF-2.1.1.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils multilib flag-o-matic apache-module autotools perl-module
DESCRIPTION="Framework for the high-level development of the Evergreen ILS software"
-HOMEPAGE="http://open-ils.org/"
+HOMEPAGE="https://open-ils.org/"
MY_PN="opensrf" # upstream lowercased the tarball in 2.x
MY_P="${MY_PN}-${PV}"
-SRC_URI="http://open-ils.org/downloads/${MY_P}.tar.gz"
+SRC_URI="https://open-ils.org/downloads/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="postgres +sqlite"
DEPEND=">=www-servers/apache-2.2.9
>=dev-db/libdbi-drivers-0.8.2
>=dev-db/libdbi-0.8.2
net-im/ejabberd
- dev-libs/libmemcache
+ dev-libs/libmemcached
dev-perl/Cache-Memcached
dev-perl/Class-DBI-AbstractSearch
sqlite? ( dev-perl/DBD-SQLite )
@@ -86,14 +86,14 @@ src_configure() {
}
src_compile() {
- emake || die "main emake failed"
+ emake
cd "${PERL_S}" && S="${PERL_S}" perl-module_src_compile || die "perl-module_src_compile failed"
}
src_install() {
einfo "Doing src_install"
#emake install-verbose DESTDIR="${D}" || die "Failed to install"
- emake install DESTDIR="${D}" APXS2_INSTALL="-i" || die "Failed to install"
+ emake install DESTDIR="${D}" APXS2_INSTALL="-i"
apache-module_src_install || die "apache-module_src_install failed"
cd "${PERL_S}" && S="${PERL_S}" perl-module_src_install || die "perl-module_src_install failed"
cd "${S}"
@@ -103,7 +103,7 @@ src_install() {
}
src_test() {
- emake check || die "emake check failed"
+ emake check
cd "${PERL_S}" && S="${PERL_S}" perl-module_src_test || die "perl-module_src_test failed"
}