summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-04-27 23:23:25 +0300
committerDavid Seifert <soap@gentoo.org>2017-05-04 18:27:54 +0200
commit0ffcf038396102e1cabec9d552e12a91659ce76a (patch)
tree166aab10737785046dfcc7068f0f93dc161adf44
parentmedia-video/mpv: map opengl USE to 'opengl' video output in 9999 (diff)
downloadgentoo-0ffcf038.tar.gz
gentoo-0ffcf038.tar.bz2
gentoo-0ffcf038.zip
media-video/mpv: notify users about new opengl USE semantics in 9999
I'm very nice. Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--media-video/mpv/mpv-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 6db8024521a4..7b17c8bd540d 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -309,13 +309,15 @@ pkg_preinst() {
}
pkg_postinst() {
- local rv softvol_0_18_1=0 osc_0_21_0=0
+ local rv softvol_0_18_1=0 osc_0_21_0=0 opengl_0_25_0=0
for rv in ${REPLACING_VERSIONS}; do
version_compare ${rv} 0.18.1
[[ $? -eq 1 ]] && softvol_0_18_1=1
version_compare ${rv} 0.21.0
[[ $? -eq 1 ]] && osc_0_21_0=1
+ version_compare ${rv} 0.25.0
+ [[ $? -eq 1 ]] && ! use opengl && opengl_0_25_0=1
done
if [[ ${softvol_0_18_1} -eq 1 ]]; then
@@ -336,6 +338,12 @@ pkg_postinst() {
elog
fi
+ if [[ ${opengl_0_25_0} -eq 1 ]]; then
+ elog "Since version 0.25.0 the 'opengl' USE flag is mapped to"
+ elog "the 'opengl' video output and no longer depends on X11"
+ elog "or Mac OS Aqua. Consider enabling the 'opengl' USE flag."
+ fi
+
# bash-completion < 2.3-r1 already installs (mostly broken) mpv completion.
if use cli && ! has_version '<app-shells/bash-completion-2.3-r1' && \
! has_version 'app-shells/mpv-bash-completion'; then