summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-15 19:34:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-15 19:37:58 +0100
commit1018276d3ffadea57665af15ce0371068d4b7a48 (patch)
tree445421d793d3eb1bb7d1f6c6c78de5b14f3a75c8
parentxfce-extra/tumbler: Bump to 0.3.1 (diff)
downloadgentoo-1018276d3ffadea57665af15ce0371068d4b7a48.tar.gz
gentoo-1018276d3ffadea57665af15ce0371068d4b7a48.tar.bz2
gentoo-1018276d3ffadea57665af15ce0371068d4b7a48.zip
dev-python/dogpile-cache: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index def0d0d60d28..8c49b16b89b0 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.0.2.tar.gz 351221 BLAKE2B 7cca7e0c260ca68fb26c0db5b736de1e3586f22a14558b8b294dfd12452cd55d70eb75b7a01041001d1d8f5300d4b7d5b5c9ff9e52dc066514d908ae188a6f97 SHA512 b49e9005916636aff0a25b9158923ea9362b3edf1f42704d06e65b14892d0cdb6b1da7d620f10d752efb1ae1987a9187b0f642cc30d07de3fc961921e1794a87
+DIST dogpile.cache-1.1.0.tar.gz 365988 BLAKE2B c21b52d23566a9d1b607374a77e2b7cc0ff0705d02cd3fddee1f6110555cf082fc9e516ba37e8ddaf7c70253dd28301cc89c3d3ef5405728859263e2a763608c SHA512 48627e4124bd25678059985c49ffde75d49d987c429d1e9a02ddd60a77b20e41899da30ae78e0f2891ff76a9c3d72a6ec782e829d659c3048cdbc921022ebb55
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.0.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.0.ebuild
new file mode 100644
index 000000000000..b7c24a92cab6
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest