summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2023-11-01 20:28:42 +0200
committerMart Raudsepp <leio@gentoo.org>2023-11-01 21:04:10 +0200
commit1024b0fb4b1cbf26c1ab7fdafcc980a3985562e5 (patch)
tree19e364be636af37772a022fde1f5f9660d5c96c6
parentx11-wm/mutter: Fix live ebuild subslot and sync with releases (diff)
downloadgentoo-1024b0fb4b1cbf26c1ab7fdafcc980a3985562e5.tar.gz
gentoo-1024b0fb4b1cbf26c1ab7fdafcc980a3985562e5.tar.bz2
gentoo-1024b0fb4b1cbf26c1ab7fdafcc980a3985562e5.zip
gnome-base/gnome-shell: add 45.1
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-base/gnome-shell/Manifest1
-rw-r--r--gnome-base/gnome-shell/gnome-shell-45.1.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 09b1c88b8d9a..b54035dcaf3b 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-44.3.tar.xz 1995132 BLAKE2B cca266dc20de2a7e99590c72c68df07c0e1d3a3eda0aa2ceb8985202ce21be937df0d80089a9266a847eda485a823ae357dd894fb1c3e64bd77063d260547cc3 SHA512 0b8ce9b99f6276939faf8623c236fdb646e16609f1f9081e768f116cd19156f2d6c6da9a059783cbc0b2a0df5b5b748369a6bce0b728338092a3fe3b81cc14b6
DIST gnome-shell-44.4.tar.xz 1998208 BLAKE2B 951daccd448a353bde0503585393c1e8c870aa3bd86149639d7c85744c4eebfe0c44488bdb0012883ae17e428e895268a0a687c6901c5797f58dfa87ff26779f SHA512 03a29a7e662a93388981f4ae7186e135ce3e687c99318a8a27ba898fcd43114a27b5351227958ce17b239bde88442d9058c64bea2c6b027cc4f6ff2e194777d5
DIST gnome-shell-45.0.tar.xz 2018936 BLAKE2B 2606725c870f6fabc671034e909bd121a10c4f95a225216e5eff9af728422fbd42f26be1e21fe9795b75b89c644442cade93392cd8fe49fb4193303ae666e93d SHA512 cdf4bc58056b97f4a19f594ea5374d69ca5d2efc5d2a5330cc1d2b2c62719dac70134df6dcd6090551adf13be12a38a0e1e4480ee55884ebbd7afe918b3c53b6
+DIST gnome-shell-45.1.tar.xz 2017464 BLAKE2B f3e6fc28e05a2eb7a6ba9f0e99b33bf0aaa46e5e1e6e302331354e67c2caa380313017232e2ccc262d29ee52c79fb847d26eb05dc098f2c69105520a7a65e80a SHA512 cfecddd3787e0e719c00d0a543466165d94431086c1ca708cf7ebd43de42f8edf468ab46212b6120ca5676d61825c085232db509c076ecf38d159702fc13a861
diff --git a/gnome-base/gnome-shell/gnome-shell-45.1.ebuild b/gnome-base/gnome-shell/gnome-shell-45.1.ebuild
new file mode 100644
index 000000000000..22a92ed100bb
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-45.1.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson optfeature python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell https://gitlab.gnome.org/GNOME/gnome-shell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind gtk-doc +ibus +networkmanager pipewire systemd test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.46.0:=
+ >=app-crypt/gcr-3.90.0:4=[introspection]
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.73.1[cairo]
+ >=gui-libs/gtk-4:4[introspection]
+ >=x11-wm/mutter-45.0:0/13[introspection,test?]
+ >=sys-auth/polkit-0.120_p20220509[introspection]
+ >=gnome-base/gsettings-desktop-schemas-42_beta[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-40.0:4=
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ )
+ pipewire? ( >=media-video/pipewire-0.3.49:= )
+ systemd? (
+ >=sys-apps/systemd-246:=
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd]
+ )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-libs/libpulse-2[glib]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/libglvnd[X]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 9. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 10. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue:2.0[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:3.0[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+ gui-libs/libadwaita:1[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data
+ )
+ ibus? ( >=app-i18n/ibus-1.5.26[gtk3,gtk4,introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gnome
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[networkmanager(+)?]
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ sys-apps/dbus
+ x11-wm/mutter[test]
+ )
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/40.0-defaults.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Hack in correct python shebang
+ sed -e "s:python\.full_path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use pipewire camera_monitor)
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Reset variables to avoid issues from /etc/profile.d/flatpak.sh file modifying XDG_DATA_DIRS
+ gnome2_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ optfeature "Bluetooth integration" gnome-base/gnome-control-center[bluetooth] net-wireless/gnome-bluetooth:3[introspection]
+ optfeature "Browser extension integration" gnome-extra/gnome-browser-connector
+ optfeature "Screencast/capture support" media-video/pipewire media-libs/gstreamer[introspection] media-libs/gst-plugins-base[introspection] media-libs/gst-plugins-good media-plugins/gst-plugins-vpx
+ optfeature "Weather support" dev-libs/libgweather:4[introspection]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}