summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-13 03:58:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-13 04:12:08 +0200
commit104bd84b7b711383f83d5d11ef7aa587d0272309 (patch)
tree9bcd40ce70d347bcbb1322790ce1c24589910d17
parentdev-python/pyfakefs: Bump to 5.5.0 (diff)
downloadgentoo-104bd84b7b711383f83d5d11ef7aa587d0272309.tar.gz
gentoo-104bd84b7b711383f83d5d11ef7aa587d0272309.tar.bz2
gentoo-104bd84b7b711383f83d5d11ef7aa587d0272309.zip
dev-python/griffe: Bump to 0.45.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.45.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index 95bfd6389703..3704a7f02f9e 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1,2 +1,3 @@
DIST griffe-0.43.0.gh.tar.gz 226278 BLAKE2B c73edf303bb44ac714aca8b9516b332183d1b2d8465aabf3725ce3eabf44325660b05a183492535892cdd227065a41d4d8f808ddfb0204641b12495488bb3862 SHA512 34dbe13414d8f6df8a7fe486f542e195a235644c28b55717fe8abb7197780f51c05ff77a633f236cb09d5072a181fb5bac06e962db1d7d820fcd4316f5cdd471
DIST griffe-0.44.0.gh.tar.gz 226269 BLAKE2B fd22ed9d11b9016307cd6cb519b7248b9afc2759eb20db2c2d1099f35ae804c9135ba241f1913d146154ff1ee917b9190ebda3fab3268b1b649a4cc925a15ade SHA512 6a60caec49ddc0496bacb5bb1c5a43cb6f56c1513d681b2c9a99a6acc2858ed465a0abacf564fe02c71bcf9ffccccf996c50bfebd005df7855e33852c1a1a955
+DIST griffe-0.45.0.gh.tar.gz 230227 BLAKE2B 9baaf356fe766ffa4537329955dd889e464e9d4521c8c3c35121a8b447de3d1ce6f9a5f91c6141af2bf4aeae02fad478155a705069957570036c53a40061e69f SHA512 36eb1bb70aa9b7888506c6ad13b8d4dadbccfce4d63924eddd3d4d90936c8b2588edbac9181fcd6e649a5945213402da63df8eb753c46db3db94e36ae5df4435
diff --git a/dev-python/griffe/griffe-0.45.0.ebuild b/dev-python/griffe/griffe-0.45.0.ebuild
new file mode 100644
index 000000000000..73f99c53e1af
--- /dev/null
+++ b/dev-python/griffe/griffe-0.45.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)