summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-02 07:31:13 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-02 07:31:51 +0100
commit105efbe1de44246324336e33093e067be5d8949b (patch)
tree786db757de7be0e5baec40da88a05e39f19934e4
parentdev-ruby/oauth2: add 1.4.3 (diff)
downloadgentoo-105efbe1de4.tar.gz
gentoo-105efbe1de4.tar.bz2
gentoo-105efbe1de4.zip
dev-ruby/pg: add 1.2.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/pg/Manifest1
-rw-r--r--dev-ruby/pg/pg-1.2.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/pg/Manifest b/dev-ruby/pg/Manifest
index 52dd737506a2..e27ecb0507fe 100644
--- a/dev-ruby/pg/Manifest
+++ b/dev-ruby/pg/Manifest
@@ -1,2 +1,3 @@
DIST pg-0.21.0.gem 214016 BLAKE2B 9e27646cd85bc97dedfb980f4851b19a1ef2aad17f6a5c60726c1683642af5c4cf87d518b300fb4c894e1580f808f8af6158b57f1ac25971c1fc55818abee6f4 SHA512 590a8c34487d2cf030082cfff87b2cc83b636df06a931e394acfb098ecb5728e793d777f125b036ee9953bbd21ec5facf91c932930acccb507d3394f2fc4cc5b
DIST pg-1.1.4.gem 233984 BLAKE2B 5a92ca49f8e471905286c07dc468f2932461f73fba13d2786c50883b271e2528b4476a81737023c252e75784c49113aacc50e1722fa100d5e97494fe60965a41 SHA512 442eadb4e9fe51aaef71cb5bbe8786c61dc4cfaa1241491270cb251f062abae88b6b2ef88dec7ab6ba2baa6390e954a2fcf4862cc95be4bc516e029c788fa1d9
+DIST pg-1.2.2.gem 196608 BLAKE2B 068be98d190cb4074cc89bdb5b376322f323950909f7a6fddc8669a3ff0f85eef9f512bd2ec7121707e9ea077b2b428f698e84f2118c76e34f5def75ca303fca SHA512 5c7cc90afb75a66e80cfc34c4875cf22b005aa0a27e78db6f71d1829f870c6409b73326a9925f79c0d642e93ea51d1f84c7383323fea44b7488e83deb7754951
diff --git a/dev-ruby/pg/pg-1.2.2.ebuild b/dev-ruby/pg/pg-1.2.2.ebuild
new file mode 100644
index 000000000000..ca23a55d9b75
--- /dev/null
+++ b/dev-ruby/pg/pg-1.2.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
+HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND+=" dev-db/postgresql:*"
+DEPEND+=" dev-db/postgresql
+ test? ( >=dev-db/postgresql-9.4[server,threads] )"
+
+all_ruby_prepare() {
+ # hack the Rakefile to make it sure that it doesn't load
+ # rake-compiler (so that we don't have to depend on it and it
+ # actually works when building with USE=doc).
+ sed -i \
+ -e '/Rakefile.cross/s:^:#:' \
+ -e '/ExtensionTask/,/^end$/ s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/*$(get_libname) lib || die
+}
+
+each_ruby_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ # Make the rspec call explicit, this way we don't have to depend
+ # on rake-compiler (nor rubygems) _and_ we don't have to rebuild
+ # the whole extension from scratch.
+ RSPEC_VERSION=3 ruby-ng_rspec
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+}