summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-01-27 22:45:21 +0000
committerMarek Szuba <marecki@gentoo.org>2023-01-27 22:49:26 +0000
commit10641446426fa0e69818ef70060513e5d08411f1 (patch)
tree2bc2bbc63c16ce1083ed2d614ef6444c2ed3fea6
parentdev-python/pefile: enable py3.11 (diff)
downloadgentoo-10641446426fa0e69818ef70060513e5d08411f1.tar.gz
gentoo-10641446426fa0e69818ef70060513e5d08411f1.tar.bz2
gentoo-10641446426fa0e69818ef70060513e5d08411f1.zip
sys-apps/fwupd-efi: add 1.4
Now with xz-compressed source tarballs! Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-apps/fwupd-efi/Manifest1
-rw-r--r--sys-apps/fwupd-efi/fwupd-efi-1.4.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/fwupd-efi/Manifest b/sys-apps/fwupd-efi/Manifest
index 0e8b6019fe90..da2a7c21860d 100644
--- a/sys-apps/fwupd-efi/Manifest
+++ b/sys-apps/fwupd-efi/Manifest
@@ -1 +1,2 @@
DIST fwupd-efi-1.3.tar.gz 39122 BLAKE2B f295869038f485026b8e60977faf76ad81f1ad11474d13be9a635b1a014daf79ee4250a44dcdb4b79f887a3093ba70a470dde6e8376bc4c064cd30c64c76cddc SHA512 3f17bc990de15e48d7be7302992d51c12b510a793b556ac269fcf3b63f83cc3c257bc852de23ee44a0de1b96eea324277015265c42ee41a11b88368a3f4b38eb
+DIST fwupd-efi-1.4.tar.xz 35984 BLAKE2B 24ce9788500781aac5b856740dc17d94bec79cf57f4f1a0359f42e6be4b9600d34259794a88f69bf83aa38ee5976b26228b20813f717edce5cc627c163585b40 SHA512 c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991
diff --git a/sys-apps/fwupd-efi/fwupd-efi-1.4.ebuild b/sys-apps/fwupd-efi/fwupd-efi-1.4.ebuild
new file mode 100644
index 000000000000..845fd79ccd63
--- /dev/null
+++ b/sys-apps/fwupd-efi/fwupd-efi-1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="EFI executable for fwupd"
+HOMEPAGE="https://fwupd.org"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fwupd/fwupd-efi.git"
+else
+ SRC_URI="https://github.com/fwupd/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="$(python_gen_any_dep '
+ dev-python/pefile[${PYTHON_USEDEP}]
+ ')
+ virtual/pkgconfig"
+
+DEPEND="sys-boot/gnu-efi"
+
+RDEPEND="!<sys-apps/fwupd-1.6.0"
+
+python_check_deps() {
+ python_has_version "dev-python/pefile[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ python_fix_shebang "${S}/efi"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Defi-libdir="${EPREFIX}"/usr/$(get_libdir)
+ -Defi_sbat_distro_id="gentoo"
+ -Defi_sbat_distro_summary="Gentoo GNU/Linux"
+ -Defi_sbat_distro_pkgname="${PN}"
+ -Defi_sbat_distro_version="${PVR}"
+ -Defi_sbat_distro_url="https://packages.gentoo.org/packages/${CATEGORY}/${PN}"
+ )
+
+ meson_src_configure
+}