summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:26:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:28 +0100
commit10668cbc13fa7b5764cf682b9bbaccb04cd253e6 (patch)
treee2165d7891a12bae5386080900cf3cc0b24fc6e7
parentdev-python/bandit: Bump to 1.7.3 (diff)
downloadgentoo-10668cbc.tar.gz
gentoo-10668cbc.tar.bz2
gentoo-10668cbc.zip
dev-python/executing: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.8.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index a39b3b6667a3..9a40d6031446 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1 +1,2 @@
DIST executing-0.8.2.gh.tar.gz 494836 BLAKE2B d6ade5658c8df656e80bb596f6c19493475d74ea10ddfc60b25eadb4a2f68d8afd2f437a6f82807932bba0469617fdac7a4dd90569623d1c8d7f96220e02ec9a SHA512 9a7fe4d3bae77d49725f35bae9d239bfb2a6e89d893d871d76f26fe4beffe0a07c6cbf50ea7b35b9ced66148d015c48106bc5774b26f201f9b40577f3380f5b3
+DIST executing-0.8.3.gh.tar.gz 495111 BLAKE2B ccb1a7df974f94b48960fc84a8365f6e57a7f34590972192e692f03340662e2bde97498c2ebf5617e45d8dfb6e866fd7de290644adb58e5338b2e0fdccc215f1 SHA512 4e01c1f48734c9568412b84160150e7e50ebdf5ba3dd466cf9d37b7f875ca2993915db75e2f6dd8e75e60b7b952fb0146928a41dde100ad38384b9be2ed60522
diff --git a/dev-python/executing/executing-0.8.3.ebuild b/dev-python/executing/executing-0.8.3.ebuild
new file mode 100644
index 000000000000..082c1bb1c0c6
--- /dev/null
+++ b/dev-python/executing/executing-0.8.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~riscv ~sparc"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}