summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2021-03-27 04:16:37 -0400
committerJames Le Cuirot <chewi@gentoo.org>2021-05-29 15:43:18 +0100
commit108710c9a2875c0b31f78b917eaa40fbd136bd59 (patch)
tree5a01f0ddc42735762166c8272d2119531dd22157
parentnet-misc/pedro: version bump (diff)
downloadgentoo-108710c9.tar.gz
gentoo-108710c9.tar.bz2
gentoo-108710c9.zip
dev-libs/ocl-icd: Remove ruby24 from USE_RUBY
dev-lang/ruby:2.4 is no longer in the gentoo tree. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild
new file mode 100644
index 000000000000..94aa219cb560
--- /dev/null
+++ b/dev-libs/ocl-icd/ocl-icd-2.2.14-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+inherit autotools flag-o-matic multilib-minimal ruby-single
+
+DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
+HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
+SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Does nothing now but by keeping it here we avoid having to have virtual/opencl
+# handle ebuilds both with and without this flag.
+IUSE="+khronos-headers"
+
+BDEPEND="${RUBY_DEPS}"
+DEPEND=">=dev-util/opencl-headers-2020.12.18"
+RDEPEND="${DEPEND}
+ !app-eselect/eselect-opencl
+ !dev-libs/opencl-icd-loader"
+
+src_prepare() {
+ replace-flags -Os -O2 # bug 646122
+
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # dev-util/opencl-headers ARE official Khronos Group headers, what this option
+ # does is disable the use of the bundled ones
+ ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers
+}
+
+multilib_src_install() {
+ default
+
+ # Drop .la files
+ find "${ED}" -name '*.la' -delete || die
+}